hdu-2548Kindergarten(二分图最大团问题)

这道题的意思是让最大可能的选出一些孩子,并且所有的孩子都要相互认识,每一个人都相互认识才可以;
这道题的就是通俗点就是说每一个节点都要有与它相连接的边,所以可以将此问题归并到最大团问题,在这里我用的是二分图最大团的第二类解题方法:补图的最大独立集;
最大独立集是说尽可能的选出最多的点但是任意两个点都不能连接,所以他的反面也就是任意一个点都有点与它相连接成边;
下面是原题:
In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.
Input
The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.
Output
For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.
Sample Input
2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0
Sample Output
Case 1: 3
Case 2: 4
AC代码:

#include<stdio.h>
#include<string.h>
int e[205][205],book[205];
int match[205];
int n,m;
int dfs(int u)
{
    for(int i=1; i<=m; ++i)
    {
        if(e[u][i]==0&&book[i]==0)
        {
            book[i]=1;
            if(match[i]==0||dfs(match[i]))
            {
                match[i]=u;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int a,b,k,t=0;
   while(scanf("%d %d %d",&n,&m,&k),n!=0&&m!=0&&k!=0)
   {
        memset(e,0,sizeof(e)); 
	    int sum=0;
        for(int i=1; i<=k; i++)
        {
            scanf("%d %d",&a,&b);
            e[a][b]=1;
        }
        memset(match,0,sizeof(match));
        for(int i=1; i<=n; ++i)
        {
            memset(book,0,sizeof(book));
            if(dfs(i))
                sum++;
        }
        printf("Case %d: %d\n",++t,n+m-sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

皮皮皮皮皮皮皮卡乒

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值