编写程序读取一系列整数,找出它们的最大数,然后计算该数的出现次数,假定输入以0结束。

编写程序读取一系列整数,找出它们的最大数,然后计算该数的出现次数,假定输入以0结束。输入格式

在一行中输入待统计的整型数,各个数可以以一个或多个空格或回车分隔,以0结束。

输出格式:

以两行输出: 第一行格式:The largest number is 最大数 第二行格式:The occurrence count of the largest number is 出现次数

输入样例:在这里给出一组输入。例如:

3 5 2 5 5 5 0

输出样例:

The largest number is 5
The occurrence count of the largest number is 4

package findmax;
import java.util.Scanner;
public class findmax {
	public static void main(String[] args) {
		Scanner input=new Scanner(System.in);
	    System.out.println(":");
		int a=input.nextInt();
		int max=a;
		int count=1;
		int i=1;
		while(a!=0)
		{
			if(max<a)
			{
				max=a;
				count=1;
			}
			else if(max==a)
			{
				if(i==1)
				count=1;
				else
				count++;
			}
		 a=input.nextInt();
		 i++;
		}
		System.out.println("The largest number is "+max);
		System.out.println("The occurrence count of the largest number is "+count);
	}
}

注意输入0的时候以及输入只有一个数的时候,代码有不妥的地方,解决办法不是很到位。欢迎指正!

  • 12
    点赞
  • 22
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值