Bone Collector(01背包)

                                               Bone Collector

Problem Description:Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
InputThe first line contain a integer T , the number of cases. Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
OutputOne integer per line representing the maximum of the total value (this number will be less than 2[sup]31[/sup]).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14
代码:
题意:
第一行整数T,接下来是T个案例,每个案例有三行,第一行包含两个整数N,V,(N <= 1000,V <= 1000)表示骨骼的数量和他的包的体积。第二行包含表示每个骨骼值的N个整数。第三行包含表示每个骨骼体积的N个整数

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int t,n,v;///t组样例,n件物品,v为背包容量
int jiazhi[1001],tiji[1001],f[1001];
///01背包模板
void ZeroOnePack(int value,int volume)
{
  for(int i=v;i>=volume;i--)
  f[i]=max(f[i],f[i-volume]+value);///状态转移方程
}
int main()
{
  cin>>t;
  while(t--)
  {
    memset(f,0,sizeof(f));///初始化边界(多组测试样例时,清零操作一定要放在while里面)
    cin>>n>>v;
    for(int i=1;i<=n;i++)
     cin>>jiazhi[i];
    for(int i=1;i<=n;i++)
     cin>>tiji[i];
    for(int i=1;i<=n;i++)
    ZeroOnePack(jiazhi[i],tiji[i]);
    /*3个for循环必须分开写,如果写在一个for循环里 就是输入一个价值输入一个体积 调用一次背包
    for(int i=1; i<=N; i++)
            cin>>v[i];
            cin>>w[i];
            onezeropack(v[i],w[i]); 这样写是不对的*/
    cout<<f[v]<<endl;
  }
}

感悟:初学背包,牢记模板才能套用模板,理解模板才能知道用哪种模板。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值