动态规划-骨头收集者(一维数组,二维数组)

杭州电子科技大学骨头收集者

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input The first line contain a integer T , the number of cases. Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total
value (this number will be less than 231).

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output
14

代码

#include <iostream>

using namespace std;
int w[1010],v[1010];
int t;
int n,V;
int dp[1010][1010];
int  d[1010];
void input()
{
    cin>>n>>V;
    for(int i=1;i<=n;i++)
    {
        cin>>v[i];
    }
    for(int i=1;i<=n;i++)
    {
        cin>>w[i];
    }
}
void DP()
{
    for(int i=0;i<=V;i++)
        dp[0][i]=0;
    for(int i=1;i<=n;i++)
        for(int j=0;j<=V;j++)
        if(j>=w[i])dp[i][j]=max(dp[i-1][j],dp[i-1][j-w[i]]+v[i]);
        else dp[i][j]=dp[i-1][j];
    cout<<dp[n][V]<<endl;
}
void D()
{
    for(int i=0;i<=V;i++)
        d[i]=0;
    for(int i=1;i<=n;i++)
        for(int j=V;j>=w[i];j--)
       d[j]=max(d[j],d[j-w[i]]+v[i]);

    cout<<d[V]<<endl;
}
int main()
{
    cin>>t;
    while(t)
    {
        input();
        D();
        //DP();
        t--;
    }

    return 0;
}
/**
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line
 contain two integer N , V, (N <= 1000 , V <= 1000 )representing
 the number of bones and the volume of his bag. And the second line
 contain N integers representing the value of each bone. The third line
 contain N integers representing the volume of each bone.


Output
One integer per line representing the maximum of the total value
(this number will be less than 231).


Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
*/

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
您可以使用流来过滤二维数组。首先,将二维数组转换为流,然后使用流操作来过滤元素。 假设我们有一个名为`matrix`的二维数组,您可以按照以下步骤进行过滤: 1. 将二维数组转换为流: ```java Stream<int[]> stream = Arrays.stream(matrix); ``` 2. 使用`filter`操作来过滤元素。例如,假设您希望过滤掉所有小于10的元素: ```java stream = stream.filter(arr -> Arrays.stream(arr).allMatch(num -> num >= 10)); ``` 在上述示例中,我们使用了`allMatch`来确保二维数组中的所有元素都大于等于10。您可以根据自己的需求更改过滤条件。 3. 可选:如果您希望将过滤后的结果收集到一个新的二维数组中,可以使用`toArray`操作: ```java int[][] filteredMatrix = stream.toArray(int[][]::new); ``` 这将返回一个新的二维数组`filteredMatrix`,其中包含经过过滤后的元素。 完整的代码示例如下: ```java import java.util.Arrays; import java.util.stream.Stream; public class Main { public static void main(String[] args) { int[][] matrix = { { 1, 2, 3 }, { 4, 5, 6 }, { 7, 8, 9 } }; Stream<int[]> stream = Arrays.stream(matrix); stream = stream.filter(arr -> Arrays.stream(arr).allMatch(num -> num >= 10)); int[][] filteredMatrix = stream.toArray(int[][]::new); // 打印过滤后的二维数组 for (int[] arr : filteredMatrix) { System.out.println(Arrays.toString(arr)); } } } ``` 请注意,上述代码中的过滤条件为元素值大于等于10的情况。您可以根据自己的需求更改过滤条件。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值