Piggy-Bank(完全背包)

Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

InputThe input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.
OutputPrint exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.
Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.
题意:输入一个输入测试数据T
输入空的存钱罐的重量以及满了的重量
输入硬币种类数N
以下N行输入N种硬币每个硬币的重量以及面值
求此情况下该存钱罐至少能存的钱数,无解就输出无解
由于每个硬币的数量是不限的,所以本题是完全背包。将初始化处理一下除了dp[i][0](一维时dp[0])设为0外其他的都设为无穷大,然后就是一个裸的完全背包。
代码:

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<iostream>
#include<stdlib.h>
#include<cstring>
using namespace std;
//int N,w[501],v[501],V,dp[10010];//为什么定义在外面 可以 定义在main函数里面就不行??????????!!!!!!!!
const int INF=0x3f3f3f3f;
int main()
{
    int T,E,F,i,j;
    int N,w[501],v[501],V,dp[10010];//定义在里面也行哎 哈哈
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d",&E,&F);
        V=F-E;//V 相当于能装的 重量
        scanf("%d",&N);
        for(i=0;i<N;i++)
            scanf("%d %d",&w[i],&v[i]);//w[i]就是P 每种硬币的价值; v[i]就是W 每种硬币的重量
        for(i=0;i<=V;i++)//i必须<=V 不能<V
            dp[i]=INF;//背包初始化为无穷
        dp[0]=0;//不明白 为什么要有一行这个
        for(i=0;i<N;i++)//每种硬币最多N个  N次循环
        for(j=v[i];j<=V;j++)
            if(dp[j-v[i]]<INF)//这行判断不要也行
            dp[j]=min(dp[j],dp[j-v[i]]+w[i]);
        if(dp[V]>=INF)//dp[V]不可能>INF 可以写成if(dp[V]==INF
            printf("This is impossible.\n");
        else
            printf("The minimum amount of money in the piggy-bank is %d.\n",dp[V]);
    }
}

感悟:都在代码里注释了。还是要确定这是一道什么类型的题,才能知道套用哪个模板,这就要求理解模板,牢记模板。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值