网络类型大实验

在这里插入图片描述在这里插入图片描述

题目要求:

1、R5为ISP,只能进行ip地址配置;其所有接口配置为公有ip地址
2、R1与R5间使用PPP的PAP认证,R5为主认证方;R2与R5间使用PPP的chap认证,R5为主认证方;R3与R5间使用HDLC封装
3、R1/2/3构建一个MGRE环境,R1为中心站点;R1/4间为点到点GRE
4、整个私有网络基于RIP全网可达
5、所有路由器基于环回私有地址为源ip时,可以正常访问R5环回

解题思路:

1、网络部署——拓扑的搭建
2、底层部署——IP地址规划配置保证全网底层都有IP
R1-R4私网网段:192.168.1.0/24——192.168.4.0/24
公网各路由器间15.1.1.0/24;25.1.1.1/24;35.1.1.1/24;45.1.1.1/24
tunnel口地址:10.1.1.1 /24;——10.1.1.3/24;10.2.2.1/24-10.2.2.2/24
链路接口认证也是底层部署的一部分
R1和R5之间的PPP认证,R5为主认证方:

[R5]aaa //主认证方——服务端
[R5-aaa]local-user huawei password cipher huawei123
Info: Add a new user.
[R5-aaa]local-user huawei service-type ppp
[R5-aaa]int s4/0/0   //连接客户端接口
[R5-Serial4/0/0]link-protocol ppp
[R5-Serial4/0/0]ppp authentication-mode pap
[R5-Serial4/0/0]ip address 15.1.1.2 24
[R5-Serial4/0/0]q

[R1]int s4/0/0   //被认证方
[R1-Serial4/0/0]link-protocol ppp
[R1-Serial4/0/0]ppp pap local-user huawei password cipher huawei123
[R1-Serial4/0/0]ip address 15.1.1.1 24

R2与R5间使用PPP的chap认证:

[R5]aaa //主认证方
[R5-aaa]local-user qq password  cipher qq123
Info: Add a new user.
[R5-aaa]local-user qq service-type ppp
[R5-aaa]int s4/0/1
[R5-Serial4/0/1]link-protocol ppp
[R5-Serial4/0/1]ppp authentication-mode chap
[R5-Serial4/0/1]ip address 25.1.1.1 24

[R2]int s4/0/1   //被认证方
[R2-Serial4/0/1]link-protocol ppp
[R2-Serial4/0/1]ppp chap user qq
[R2-Serial4/0/1]ppp chap password cipher qq123
[R2-Serial4/0/1]ip address 25.1.1.2 24

R3与R5间使用HDLC封装:

[R3-LoopBack0]int s4/0/0
[R3-Serial4/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y
[R3-Serial4/0/0]ip address 35.1.1.2 24

[R5]int s3/0/0
[R5-Serial3/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y
[R5-Serial3/0/0]ip address 35.1.1.1 24

3、路由保证全网可达——各路由器缺省指向R5

[R1]ip route-static 0.0.0.0 0 15.1.1.2
[R2]ip route-static 0.0.0.0 0 25.1.1.1
[R3]ip route-static 0.0.0.0 0 35.1.1.1
[R4]ip route-static 0.0.0.0 0 45.1.1.1

R1-4做net使得所有路由器基于环回私有地址为源ip时,可以正常访问R5环回。

[R1]acl 2000
[R1-acl-basic-2000]rule 5 permit source 192.168.1.0 0.0.0.255
[R1-acl-basic-2000]q
[R1]int s4/0/0
[R1-Serial4/0/0]nat outbound 2000
[R1-Serial4/0/0]display nat outbound 
 NAT Outbound Information:
 --------------------------------------------------------------------------
 Interface                     Acl     Address-group/IP/Interface      Type
 --------------------------------------------------------------------------
 Serial4/0/0                  2000                       15.1.1.1    easyip  
 --------------------------------------------------------------------------

[R2]acl 2000
[R2-acl-basic-2000]rule 5 permit source 192.168.2.0 0.0.0.255
[R2-acl-basic-2000]q
[R2]int s4/0/1
[R2-Serial4/0/1]nat outbound 2000

[R3]acl 2000
[R3-acl-basic-2000]rule 5 permit source 192.168.3.0 0.0.0.255
[R3-acl-basic-2000]q
[R3]int s4/0/0
[R3-Serial4/0/0]nat outbound 2000
[R3-Serial4/0/0]display nat outbound 

[R4]acl 2000
[R4-acl-basic-2000]rule 5 permit source 192.168.4.0 0.0.0.255
[R4-acl-basic-2000]q
[R4]int g0/0/0
[R4-GigabitEthernet0/0/0]nat outbound 2000
[R4-GigabitEthernet0/0/0]display nat outbound 

配置这一部分的时候遇到了两大问题:1)各路由器不能使用环回去pingR5的环回,这样做nat也是拼不通的,只能再额外加上一台PC。才可以ping通。2)在写PC3的时候网关地址和主机地址写错了导致一直没有ping通后来检查了几遍才通。
4、R1/2/3构建一个MGRE环境,R1为中心站点

中心站点:
[R1]int Tunnel 0/0/0
[R1-Tunnel0/0/0]ip address 10.1.1.1 255.255.255.0
[R1-Tunnel0/0/0]tunnel-protocol gre p2mp 
[R1-Tunnel0/0/0]source 15.1.1.1 
Sep 28 2020 17:54:51-08:00 R1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/0 has entered the UP state. 
[R1-Tunnel0/0/0]nhrp entry multicast dynamic 
[R1-Tunnel0/0/0]nhrp network-id 100
[R1-Tunnel0/0/0]display nhrp peer all
------------------------------------------------------------------------------- 
Protocol-addr   Mask  NBMA-addr       NextHop-addr    Type         Flag         
------------------------------------------------------------------------------- 
10.1.1.2        32    25.1.1.2        10.1.1.2        dynamic      route tunnel 
------------------------------------------------------------------------------- 
Tunnel interface: Tunnel0/0/0
Created time    : 00:02:22
Expire time     : 01:57:38
------------------------------------------------------------------------------- 
Protocol-addr   Mask  NBMA-addr       NextHop-addr    Type         Flag         
------------------------------------------------------------------------------- 
10.1.1.3        32    35.1.1.2        10.1.1.3        dynamic      route tunnel 
------------------------------------------------------------------------------- 
Tunnel interface: Tunnel0/0/0
Created time    : 00:00:31
Expire time     : 01:59:29

Number of nhrp peers: 2
分支站点:
[R2]int Tunnel 0/0/0
[R2-Tunnel0/0/0]ip address 10.1.1.2 255.255.255.0
[R2-Tunnel0/0/0]tunnel-protocol gre p2mp 
[R2-Tunnel0/0/0]source Serial 4/0/1
Sep 28 2020 18:17:30-08:00 R2 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/0 has entered the UP state. 
[R2-Tunnel0/0/0]nhrp network-id 100
[R2-Tunnel0/0/0]nhrp entry 10.1.1.1 15.1.1.1 re
[R2-Tunnel0/0/0]display nhrp peer all
------------------------------------------------------------------------------- 
Protocol-addr   Mask  NBMA-addr       NextHop-addr    Type         Flag         
------------------------------------------------------------------------------- 
10.1.1.1        32    15.1.1.1        10.1.1.1        static       hub          
------------------------------------------------------------------------------- 
Tunnel interface: Tunnel0/0/0
Created time    : 00:00:30
Expire time     : --

Number of nhrp peers: 1

[R3]int Tunnel 0/0/0
[R3-Tunnel0/0/0]ip address 10.1.1.3 255.255.255.0
[R3-Tunnel0/0/0]tunnel-protocol gre p2mp 
[R3-Tunnel0/0/0]source s4/0/0
Sep 28 2020 18:19:18-08:00 R3 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/0 has entered the UP state. 
[R3-Tunnel0/0/0]nhrp network-id 100
[R3-Tunnel0/0/0]nhrp entry 10.1.1.1 15.1.1.1 register 
[R3-Tunnel0/0/0]display nhrp peer all
------------------------------------------------------------------------------- 
Protocol-addr   Mask  NBMA-addr       NextHop-addr    Type         Flag         
------------------------------------------------------------------------------- 
10.1.1.1        32    15.1.1.1        10.1.1.1        static       hub          
------------------------------------------------------------------------------- 
Tunnel interface: Tunnel0/0/0
Created time    : 00:00:16
Expire time     : --

Number of nhrp peers: 1

R1/4间为点到点GRE

[R1]int Tunnel 0/0/1
[R1-Tunnel0/0/1]ip address 10.2.2.1 24
[R1-Tunnel0/0/1]tunnel-protocol gre
[R1-Tunnel0/0/1]source 15.1.1.1
[R1-Tunnel0/0/1]destination 45.1.1.2
Sep 28 2020 18:12:33-08:00 R1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/1 has entered the UP state. 

[R4]int Tunnel 0/0/1
[R4-Tunnel0/0/1]ip address 10.2.2.2 24
[R4-Tunnel0/0/1]tunnel-protocol gre
[R4-Tunnel0/0/1]source 45.1.1.2
[R4-Tunnel0/0/1]destination 15.1.1.1
Sep 28 2020 18:34:38-08:00 R4 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/1 has entered the UP state. 

4、整个私有网络基于RIP全网可达——配置rip并在R1上打破水平分割,否则部分学不到路由。

[R1]rip 1
[R1-rip-1]version 2
[R1-rip-1]network 192.168.1.0 
[R1-rip-1]network 10.0.0.0

[R2]rip 1
[R2-rip-1]version 2
[R2-rip-1]network 192.168.2.0
[R2-rip-1]network 10.0.0.0

[R3]rip 1
[R3-rip-1]version 2
[R3-rip-1]network 192.168.3.0
[R3-rip-1]network 10.0.0.0

[R4]rip 1
[R4-rip-1]version 2
[R4-rip-1]network 192.168.4.0
[R4-rip-1]network 10.0.0.0

在R1上打破水平分割

[R1-Tunnel0/0/0]undo rip split-horizon 

至此,实验完成。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值