HDU 2056 Rectangles(不要想太多的)

Rectangles

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 38013 Accepted Submission(s): 12470

Problem Description
Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .

Input
Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).

Output
Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.

Sample Input
1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50

Sample Output
1.00
56.25

对角线,不要考虑太多的或者想太多!我们是由简单到繁琐

#include<iostream>
using namespace std;
#include<iomanip>
//swap的作用:1,将对角线两种对角线统一转化为左下角到右上角。2,将顺序调整,保证对角线的左下角的横纵坐标都小于右上角的横纵坐标

//采用引用无需返回值,更高效快捷
void swap(double &x,double &y)//交换数据
	double temp;
	if(x>y)
	{
		temp=x;
		x=y;
		y=temp;
	}
}
int main()
{
	double x1,y1,x2,y2,x3,y3,x4,y4;
	double a,b,c,d;
	double sum;
	while(cin>>x1>>y1>>x2>>y2>>x3>>y3>>x4>>y4)
	{
		swap(x1,x2);
		swap(y1,y2);
		swap(x3,x4);
		swap(y3,y4);
		if(x3>=x2||y3>=y2||x4<=x1||y4<=y1)
			sum=0;
		else
		{/*不止这两种情况(可能还存在包含关系,比喻第二个矩形的两个横坐标都在第一个矩形的两个横坐标范围内,即第一个矩形包含第二个矩形)
			// if(x3>=x1&&x3<x2)
			// {
				// sum=(x2-x3)*(y2-y3);
				
			// }
			// if(x4>=x1&&x4<x2)
			// {
				// sum=(x4-x1)*(y4-y1);
			// }*/
			
			a=x1>x3?x1:x3;
			b=x2>x4?x4:x2;
			c=y1>y3?y1:y3;
			d=y2>y4?y4:y2;
			//包含啦你想到的所有的情况!
			sum=(b-a)*(d-c);
			//因为存在包含关系
		}
		cout<<setiosflags(ios::fixed)<<setprecision(2)<<sum<<endl;
	}
	return 0;
}
			
		
		
	
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值