G - Pairing Socks Kattis - pairingsocks 栈的应用

Simone’s mother often complains about how Simone never helps with chores at home. In return, Simone often points out that many of the chores her mother assigns her are NP-complete to perform optimally (like cleaning the house, seating her little brothers around the dinner table in a conflict-free way, splitting the brothers’ Halloween loot in a fair manner and so on).
Being a computer scientist, her mother finds this a fair objection. Looking over her list of potential chores, she picked one she thinks should be easy to solve – pairing a number of different kinds of socks.

In the beginning, there are 2n2n socks stacked in a pile. To pair the socks, Simone can repeatedly make one of three moves:

Move the sock from the top of the original pile to the top of an auxiliary pile (which is originally empty).

Move the sock from the top of the auxiliary pile to the top of the original pile.

Pair the top socks from each pile together, if they are of the same type.

Simone only has one auxiliary pile, for a total of two piles. There may be more than two socks of each type. In this case, Simone can pair them up however she wants.

Your task is to help Simone to determine the least number of moves she needs to pair the socks, if it is possible at all.

Input

The first line of input contains the integer nn (1≤n≤1051≤n≤105) as described above. The next line contains 2n2n integers a1,…,a2na1,…,a2n (1≤ai≤1091≤ai≤109 for each ii), where aiai denotes the type of sock number ii. Initially, sock 11 is at the top of the pile and sock 2n2n is at the bottom.

Output

If Simone can pair all the socks, output the least number of moves she needs to do this. If it is impossible to do so, output “impossible” (without the quotes).

Sample Input 1 Sample Output 1
2
1 2 2 1
4
Sample Input 2 Sample Output 2
1
3 7
impossible
Sample Input 3 Sample Output 3
3
5 5 5 5 5 5
6

水题,比赛的时候因为数组开成了1e5,导致这题卡了好久。

用栈

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<stack>
using namespace std;
const int maxx = 2e5+10;
int a[maxx];
int b[maxx];

int main()
{
    int n;
    while(cin>>n)
    {
        int i;
        n*=2;
        for(i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        int k = -1;
       i = 0;
       while(i<n)
       {
           if(k==-1)
           {
               b[++k] = a[i];
               i++;
           }
           else
           {
               if(b[k]==a[i])
               {
                   i++;
                   k--;
               }
               else
               {
                   b[++k] = a[i];
                   i++;
               }
           }
       }
       if(k==-1)
        printf("%d\n",n);
       else
        printf("impossible\n");
    }
    return 0;
}
#include<iostream>
#include<stdio.h>
#include<cstring>
#include<stack>
using namespace std;
const int maxx = 2e5+10;
int a[maxx];
int b[maxx];

int main()
{
    int n;
    cin>>n;
    int i;
    n*=2;
    int cnt = 0;
    for(i=0; i<n; i++)
    {
        scanf("%d",&a[i]);
        cnt++;
        if(a[i]==a[i-1]&&i>0)
        {
            i -=2;   //只要找到两个相同的就消除他们
        }
        if(cnt>=n)
            break;
    }
    if(i==-1)
        printf("%d\n",n);
    else
        printf("impossible\n");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip 【备注】 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用!有问题请及时沟通交流。 2、适用人群:计算机相关专业(如计科、信息安全、数据科学与大数据技术、人工智能、通信、物联网、自动化、电子信息等)在校学生、专业老师或者企业员工下载使用。 3、用途:项目具有较高的学习借鉴价值,不仅适用于小白学习入门进阶。也可作为毕设项目、课程设计、大作业、初期项目立项演示等。 4、如果基础还行,或热爱钻研,亦可在此项目代码基础上进行修改添加,实现其他不同功能。 欢迎下载!欢迎交流学习!不清楚的可以私信问我! 毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值