POJ 1961 (KMP求最长连续重复字串)

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K. 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it. 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case. 

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题意:输入n,输入n个字符,判断这个字符串中,任意前缀中是否有循环节,输出这个前缀长度和循环次数。(循环次数大于等于二的)

题解:利用KMP算法里的next[]数组,再适合不过了。

样例分析:3 aaa   aa:前两个字符,循环次数2,输出2 2

         aaa:前三个字符,循环次数3,输出3 3

这里是next[j] = k, 这样用j - k  就得到循环串的周期,再用 j / (j - k) 就是重复次数

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<vector>
#include<map>
#include<cmath>
#define ll long long
#define inf 0x3f3f3f3f
#define N 1010
#define M 1000010
#define mod 1000000007
using namespace std;
int next1[M];
char b[M];
int n,m;
void nextt(){
    int j=0,k=-1;
    next1[0]=-1;
    while(j<m){
        if(k==-1||b[j]==b[k]){
            j++;k++;
            next1[j]=k;
        }
        else k=next1[k];
    }
}
int main(){
    int t=1;
    while(scanf("%d",&n)!=EOF&&n){
        scanf("%s",b);
        m=strlen(b);
        nextt();
        printf("Test case #%d\n",t++);
        for(int i=1;i<=m;i++){  //核心代码
            int ans=i-next1[i];
            if(i%ans==0&&i/ans>1){
                printf("%d %d\n",i,i/ans);
            }
        }
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值