Hdu 6153 A Secret(KMP求子串在母串中的前缀长度和)

Today is the birthday of SF,so VS gives two strings S1,S2 to SF as a present,which have a big secret.SF is interested in this secret and ask VS how to get it.There are the things that VS tell: 
  Suffix(S2,i) = S2[i...len].Ni is the times that Suffix(S2,i) occurs in S1 and Li is the length of Suffix(S2,i).Then the secret is the sum of the product of Ni and Li. 
  Now SF wants you to help him find the secret.The answer may be very large, so the answer should mod 1000000007.

Input

Input contains multiple cases. 
  The first line contains an integer T,the number of cases.Then following T cases.
  Each test case contains two lines.The first line contains a string S1.The second line contains a string S2. 
  1<=T<=10.1<=|S1|,|S2|<=1e6.S1 and S2 only consist of lowercase ,uppercase letter.

Output

For each test case,output a single line containing a integer,the answer of test case. 
  The answer may be very large, so the answer should mod 1e9+7.

Sample Input

2
aaaaa
aa
abababab
aba

Sample Output

13
19

        
  

Hint

case 2: 
Suffix(S2,1) = "aba",
Suffix(S2,2) = "ba",
Suffix(S2,3) = "a".
N1 = 3,
N2 = 3,
N3 = 4.
L1 = 3,
L2 = 2,
L3 = 1.
ans = (3*3+3*2+4*1)%1000000007.

我们首先将两个字符串倒过来,后缀变前缀,然后再最末尾各加一个不同的字符。

然后考虑KMP匹配的过程中,每拓展一个长度的匹配,就会多匹配长度的价值。

如果我们失败匹配了,那么j=next【j】之后,我们发现之前匹配上的部分还需要加上len*(len+1)/2的价值,

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<set>
#define ll long long
#define N 1000010
using namespace std;
const int M=1e9+7;
char a[N];
char b[N];
int nex[N];
int n,m;
void nexx(){
    int j=0,k=-1;
    nex[0]=-1;
    while(j<m){
        if(k==-1||b[j]==b[k]){
            j++;k++;
            nex[j]=k;
        }else k=nex[k];
    }
}
void kmp(){
    int i=0,j=0;
    nexx();
    ll ans=0;
    while(i<n){
        if(j==-1||a[i]==b[j]){
            i++;j++;
            ans+=j;
            ans%=M;
        }else{
            if(j==0)i++;
            else{
                j=nex[j];
                ans+=(ll)j*(j+1)/2;
                ans%=M;
            }
        }
    }
    printf("%lld\n",ans);
}
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%s %s",a,b);
        n=strlen(a);
        m=strlen(b);
        reverse(a,a+n);
        reverse(b,b+m);
        a[n++]='#';
        b[m++]='$';
        a[n]='\0';
        b[m]='\0';
        kmp();
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值