Tired of playing computer games, alpc23 is planning to play a game on numbers. Because plus and subtraction is too easy for this gay, he wants to do some multiplication in a number sequence. After playing it a few times, he has found it is also too boring. So he plan to do a more challenge job: he wants to change several numbers in this sequence and also work out the multiplication of all the number in a subsequence of the whole sequence.
To be a friend of this gay, you have been invented by him to play this interesting game with him. Of course, you need to work out the answers faster than him to get a free lunch, He he…
Input
The first line is the number of case T (T<=10).
For each test case, the first line is the length of sequence n (n<=50000), the second line has n numbers, they are the initial n numbers of the sequence a1,a2, …,an,
Then the third line is the number of operation q (q<=50000), from the fourth line to the q+3 line are the description of the q operations. They are the one of the two forms:
0 k1 k2; you need to work out the multiplication of the subsequence from k1 to k2, inclusive. (1<=k1<=k2<=n)
1 k p; the kth number of the sequence has been change to p. (1<=k<=n)
You can assume that all the numbers before and after the replacement are no larger than 1 million.
Output
For each of the first operation, you need to output the answer of multiplication in each line, because the answer can be very large, so can only output the answer after mod 1000000007.
Sample Input
1
6
1 2 4 5 6 3
3
0 2 5
1 3 7
0 2 5
Sample Output
240
420
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define LL long long
#define mod 1000000007
using namespace std;
LL d[200000];
void build(LL l,LL r,LL p){
if(l==r)scanf("%lld",&d[p]);
else {
LL m=(l+r)>>1;
build(l,m,p<<1);
build(m+1,r,p<<1|1);
d[p]=(d[p<<1]*d[p<<1|1])%mod;
}
}
void update(LL x,LL y,LL l,LL r,LL p){
if(l==r){
d[p]=y;return;
}
LL m=(l+r)>>1;
if(x<=m)update(x,y,l,m,p<<1);
else update(x,y,m+1,r,p<<1|1);
d[p]=(d[p<<1]*d[p<<1|1])%mod;
}
LL query(LL x,LL y,LL l,LL r,LL p){
if(x<=l&&r<=y){
return d[p];
}
LL m=(l+r)>>1;
LL sum=1;
if(x<=m)sum*=query(x,y,l,m,p<<1);
if(y>m)sum=(sum*query(x,y,m+1,r,p<<1|1))%mod;
return sum;
}
int main(){
LL T;
scanf("%lld",&T);
while(T--){
LL n,q,a,x,y;
scanf("%lld",&n);
build(1,n,1);
scanf("%lld",&q);
while(q--){
scanf("%lld %lld %lld",&a,&x,&y);
if(a){
update(x,y,1,n,1);
}else{
printf("%lld\n",query(x,y,1,n,1));
}
}
}
return 0;
}