POJ 1988 带权并查集

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.

  • In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
  • In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

有n个箱子,初始时每个箱子单独为一列;
接下来有p行输入,M, x, y 或者 C, x;
对于M,x,y:表示将x箱子所在的一列箱子搬到y所在的一列箱子上;
对于C,x:表示求箱子x下面有多少个箱子;

Input

  • Line 1: A single integer, P

  • Lines 2…P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a ‘M’ for a move operation or a ‘C’ for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

第一行一个整数P,表示操作次数。
接下来有p(1<= P <= 100,000)行输入,M, x, y 或者 C, x;(x,y<=N)
箱子的个数N,不会出现在输入中。(1 <= N <= 30,000),初始时每个箱子单独为一列;你可以认为,操作过程中,不会出现编号大意30000的箱子

Output
Print the output from each of the count operations in the same order as the input file.
对于每个询问,输出相应的值。

Sample Input
6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output
1
0
2

代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define inf 30010
using namespace std;
int par[inf];
int d[inf];
int num[inf];
void init(){
    for(int i=0;i<inf;i++){
        par[i]=i;
        d[i]=0;
        num[i]=1;
    }
}
int fi(int x){
    if(par[x]!=x){
        int pre=par[x];
        par[x]=fi(par[x]);
        d[x]+=d[pre];
        return par[x];
    }
    return x;
}
int main(){
    int n;
    while(scanf("%d",&n)!=EOF){
        init();
        while(n--){
            char s[3];
            int x,y;
            scanf("%s %d",s,&x);
            int xx=fi(x);//为什么
            if(s[0]=='M'){
                scanf("%d",&y);
                //int xx=fi(x);为什么不能放这
                int yy=fi(y);
                if(xx!=yy){
                    par[xx]=yy;
                    d[xx]=num[yy];
                    num[yy]+=num[xx];
                }
            }else{
                printf("%d\n",d[x]);
            }
        }
    }
    return 0;
}

补:

#include<iostream>
#include<cstdio>
#include<cstring>
#define ll long long
#define N 30010
using namespace std;
int par[N],sum[N],num[N];
void init(){
	for(int i=0;i<N;i++){
		par[i]=i;
		sum[i]=0;
		num[i]=1;
	}
}
int fi(int x){
	if(x!=par[x]){
		int f=par[x];
		par[x]=fi(par[x]);
		sum[x]+=sum[f];
	}
	return par[x];
}
void un(int x,int y){
	int xx=fi(x);
	int yy=fi(y);
	if(xx!=yy){
		par[xx]=yy;
		sum[xx]=num[yy];
		num[yy]+=num[xx];
	}
}
int main(){
	int n,x,y;
	char a[3];
	while(scanf("%d",&n)!=EOF){
		init();
		while(n--){
			scanf("%s",a);
			if(a[0]=='M'){
				scanf("%d %d",&x,&y);
				un(x,y);
			}else{
				scanf("%d",&x);
				int xx=fi(x);			//不能省
				printf("%d\n",sum[x]);
			}
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值