POJ 1847 火车转弯 dijkstra+邻接表

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.
When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.
Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.

Input
The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.
Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.

Output
The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer “-1”.

Sample Input
3 2 1
2 2 3
2 3 1
2 1 2

Sample Output
0

题意:输入 N,A,B表示 有N个交叉口,起点为A终点为B
输入K表示该交叉口可以去k处 且第一个是默认方向其他方向需要转变方向
思路:
对于默认方向 权值为0,其他方向权值为1 不能到达用是否走过判断

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<vector>
#define ll long long
#define inf 0x3f3f3f3f
#define N 110
using namespace std;
struct A{
    int to,cost;
    bool operator<(const A n1)const{
        return n1.cost<cost;
    };
}x;
int main(){
    int n,s,t,k,a;
    while(scanf("%d %d %d",&n,&s,&t)!=EOF){
        priority_queue<A>q;
        vector<A>v[N];
        int vis[N]={0};
        for(int i=1;i<=n;i++){
            scanf("%d",&k);
            if(k!=0){
                scanf("%d",&a);
                x.to=a;
                x.cost=0;k--;
                v[i].push_back(x);
                x.cost=1;
                while(k--){
                    scanf("%d",&a);
                    x.to=a;
                    v[i].push_back(x);
                }
            }
        }
        x.to=s;x.cost=0;
        q.push(x);
        while(!q.empty()){
            x=q.top();q.pop();
            vis[x.to]=1;
            if(x.to==t)break;
            for(int i=0,j=v[x.to].size();i<j;i++){
                A e;
                e.to=v[x.to][i].to;
                if(vis[e.to])continue;
                e.cost=x.cost+v[x.to][i].cost;
                q.push(e);
            }
        }
        if(vis[t])printf("%d\n",x.cost);   //如果不能到达,vis[t]=0;
        else printf("-1\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值