Oulipo(KMP&&哈希)

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0

解题思路

基本上是 哈希和KMP的板子题,在这里主要讲下KMP:主要就是维护一个next数组。
先给个列子比如
0 0 1 2 3 4 5
A Z A Z A Z A 下面是标号,上面是next数组,**while(s[i]!=s[next[i-1]]&&next[i-1]>0) next[i-1]=next[next[i-1]-1]; **if(s[i]==s[next[i-1]]) next[i]=next[i-1]+1;else next[i]=0 **

0 1 2 3 4 5 6
这个有什么用那,别着急看这个例子

00101232323
AZA$AZAZAZA
012345678910

我们让子串加上母串再求next数组就得到了这么的答案,等等我们发现了s[6]=3s[8]=3s[10]=3
正好是3个,答案也是3个(amazing),我讲一下next[7]是怎么求的,求next[7]我们要看s[7]是否等于s[next[6]]很明显s[7]=z,s[next[6]]=$,不成立,怎么办,看上面的式子next[6]=next[next[6]-1]=1,在比较s[next[6]]next[7]是否相等,一看相等就加一next[7]=next[6]+1=2。自己用手模拟一下。

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e5+10;
string s1,s2;
vector<int> getnxt(string t)
{
	int len= t.size();
	vector<int> nxt(len);
	for(int i=1;i<len;i++)
	{
		int j=nxt[i-1];
		while(t[i]!=t[j]&&j>0) j=nxt[j-1];//求next数组 
		if(t[i]==t[j]) j++;
	 	nxt[i]=j;
	}
	return nxt;
}

int main()
{
	ios::sync_with_stdio(0);//关下同步不然会超时
	cin.tie(0);
	cout.tie(0); 
	int t;
	cin>>t;
	while(t--)
	{
		cin>>s1>>s2;
		int len1=s1.size();
		string s3=s1+'#'+s2;//这个构造一个新的字符串 
		vector<int> nxt=getnxt(s3);
		int len2=s3.size();
		int k=0;
		for(int i=len1+1;i<len2;i++)
		{
			if(nxt[i]==len1)//枚举长度 
			{
				k++;
			}
		}
		printf("%d\n",k);	
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值