1001 A+B Format

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where 10的6次方≤a,b≤10的6次方. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

思路

a,b,a+b在int数据类型表示范围内,用int变量储存。先计算a+b,再判断正负,再输出负号。用一个char数组储存每一位数字,并计算位数。按要求输出。

代码

#include <stdio.h>
#include <stdlib.h>
#define MAXSIZE 20
int main()
{
    int a, b, c, d;
    scanf("%d %d", &a, &b);//读取
    c=a+b;//计算
    if(c<0)//判断正负
    {
        printf("-");
        c=0-c;
    }
    int num=0;
    char sum[MAXSIZE];//从最高位依次储存
    d=c;
    do{
        sum[num++]=d%10;
        d=(d-d%10)/10;
    }while(d!=0);//至少一位数字,储存数位并计算位数
    for(int i=num-1; i>=0; i--)
    {
        printf("%d",sum[i]);
        if(i!=0 && i%3==0)//下标是3的倍数且不是最后一位数字才输出逗号
        printf(",");
     }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值