最大最小表示法+kmp算法--hdu3374

题目链接:https://vjudge.net/problem/HDU-3374

Give you a string with length N, you can generate N strings by left shifts. For example let consider the string “SKYLONG”, we can generate seven strings: 
String Rank 
SKYLONG 1 
KYLONGS 2 
YLONGSK 3 
LONGSKY 4 
ONGSKYL 5 
NGSKYLO 6 
GSKYLON 7 
and lexicographically first of them is GSKYLON, lexicographically last is YLONGSK, both of them appear only once. 
  Your task is easy, calculate the lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), its times, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also. 

Input

  Each line contains one line the string S with length N (N <= 1000000) formed by lower case letters.

Output

Output four integers separated by one space, lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), the string’s times in the N generated strings, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

Sample Input

abcder
aaaaaa
ababab

Sample Output

1 1 6 1
1 6 1 6
1 3 2 3

题目大意:输出字典序最小最大开始的序列编号以及出现过几次。 

思路:用最大最小表示法即可求出开始的序列编号。

要解决出现过几次:

1.若该循环串不是由一个子串循环组成,则仅有一次。

2.若是,需要求出有几个循环结。利用kmp算法中的next[]数组即可解决(做题时没想到)。具体看代码 。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<map>
#include<set>
#include<stack>
#include<queue>
#include<vector>
#include<string>
using namespace std;
typedef long long ll;
const int INF=1e6+5;
char a[INF];
int nexts[INF];
int len,n;
void get_next()
{
	int i,j=-1;
	nexts[0]=-1;
	for(i=0;i<len;)
	{
		if(j==-1||a[i]==a[j]){
			nexts[++i]=++j;
		}
		else j=nexts[j];
	}
}
int get_min()
{
	int i=0,j=1,k=0;
	while(i<len&&j<len&&k<len)
	{
		int t=a[(i+k)%len]-a[(j+k)%len];
	    if(!t){
		    k++;
	    }
	    else
	    {
		    if(t>0)
		    {
			    i+=k+1;
		    }
		    else j+=k+1;
		    k=0;
		    if(i==j)j++;
	    }
	}
	return i>j?j:i;
}
int get_max()
{
	int i=0,j=1,k=0;
	while(i<len&&j<len&&k<len)
	{
		int t=a[(i+k)%len]-a[(j+k)%len];
	    if(!t){
		    k++;
	    }
	    else
	    {
		    if(t>0)
		    {
			    j+=k+1;
		    }
		    else i+=k+1;
		    k=0;
		    if(i==j)j++;
	    }
	}
	return i>j?j:i;
}
int main()
{
	while(scanf("%s",a)!=EOF)
	{
		len=strlen(a);
		int mi=get_min()+1,mx=get_max()+1;
		get_next();
		int l=len-nexts[len];
//		cout<<nexts[len]<<" "<<len<<endl;
		int ans=len%l?1:len/l;//对于kmp算法的理解 
		printf("%d %d %d %d\n",mi,ans,mx,ans);
	}
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值