05-树9 Huffman Codes (30 分)(C++)

05-树9 Huffman Codes (30 分)(C++)
#题目

In 1953, David A. Huffman published his paper “A Method for the Construction of Minimum-Redundancy Codes”, and hence printed his name in the history of computer science. As a professor who gives the final exam problem on Huffman codes, I am encountering a big problem: the Huffman codes are NOT unique. For example, given a string “aaaxuaxz”, we can observe that the frequencies of the characters ‘a’, ‘x’, ‘u’ and ‘z’ are 4, 2, 1 and 1, respectively. We may either encode the symbols as {‘a’=0, ‘x’=10, ‘u’=110, ‘z’=111}, or in another way as {‘a’=1, ‘x’=01, ‘u’=001, ‘z’=000}, both compress the string into 14 bits. Another set of code can be given as {‘a’=0, ‘x’=11, ‘u’=100, ‘z’=101}, but {‘a’=0, ‘x’=01, ‘u’=011, ‘z’=001} is NOT correct since “aaaxuaxz” and “aazuaxax” can both be decoded from the code 00001011001001. The students are submitting all kinds of codes, and I need a computer program to help me determine which ones are correct and which ones are not.

Input Specification:
Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤63), then followed by a line that contains all the N distinct characters and their frequencies in the following format:

c[1] f[1] c[2] f[2] … c[N] f[N]
where c[i] is a character chosen from {‘0’ - ‘9’, ‘a’ - ‘z’, ‘A’ - ‘Z’, ‘_’}, and f[i] is the frequency of c[i] and is an integer no more than 1000. The next line gives a positive integer M (≤1000), then followed by M student submissions. Each student submission consists of N lines, each in the format:

c[i] code[i]
where c[i] is the i-th character and code[i] is an non-empty string of no more than 63 '0’s and '1’s.

Output Specification:
For each test case, print in each line either “Yes” if the student’s submission is correct, or “No” if not.

Note: The optimal solution is not necessarily generated by Huffman algorithm. Any prefix code with code length being optimal is considered correct.

Sample Input:
7
A 1 B 1 C 1 D 3 E 3 F 6 G 6
4
A 00000
B 00001
C 0001
D 001
E 01
F 10
G 11
A 01010
B 01011
C 0100
D 011
E 10
F 11
G 00
A 000
B 001
C 010
D 011
E 100
F 101
G 110
A 00000
B 00001
C 0001
D 001
E 00
F 10
G 11
Sample Output:
Yes
Yes
No
No

#C++代码

#include<iostream>
#include<cstring>
#define MAXWEIGHT 1000000
#define CODESIZE 100
using namespace std;
typedef struct Node Node;
struct Node
{
	int weight;
	char ch;
	Node* L;
	Node* R;
	bool flag;
};
Node* creatnode(int a)
{
	Node* p = new Node;
	p->ch = 0;
	p->weight = a;
	p->L = NULL;
	p->R = NULL;
	p->flag = false;
	return p;
}
Node* creatnode(int a,char c)
{
	Node* p = new Node;
	p->ch = c;
	p->weight = a;
	p->L = NULL;
	p->R = NULL;
	p->flag = false;
	return p;
}
int FindMin(Node** p,int N)
{
	int min = 0;
	for (int i = 1; i < N+1; i++)
	{
		if (p[i]->weight < p[min]->weight&&p[i]->flag==false)
			min = i;
	}
	return min;
}
int creattree(Node** p,int N)
{
	int min1 = 1, min2 = 1;
	while (min2)
	{
		min1 = FindMin(p,N);
		p[min1]->flag = true;
		min2 = FindMin(p,N);
		p[min2]->flag = true;
		if (min1 && min2)
		{
			Node* q = creatnode(p[min1]->weight + p[min2]->weight);
			q->R = p[min2];
			q->L = p[min1];
			p[min1] = q;
		}
	}
	return min1;
}
int num = 0;
void traverse(Node* T,int &WPL)
{
	if (T)
	{
		
		if (T->L)num++;
		traverse(T->L,WPL);
		if (T->ch)
		{
			WPL += num * T->weight;
		}
		if (T->R)num++;
		traverse(T->R,WPL);
		num--;
	}
}
int main()
{
	int N = 0;
	cin >> N;
	Node** p = new Node * [N+1] {0};
	int* w = new int[N] {0};
	char ch = 0;
	p[0] = creatnode(MAXWEIGHT);
	for (int i = 1; i <= N; i++)
	{
		cin >> ch >> w[i - 1];
		p[i] = creatnode(w[i-1], ch);
	}
	int root = creattree(p,N);
	int minWPL = 0;
	traverse(p[root], minWPL);
	int M = 0;
	cin >> M;
	char* c = new char[N];
	char** code = new char* [N] {0};
	for (int i = 0; i < N; i++)
	{
		code[i] = new char[CODESIZE] {0};
	}
	for (int i = 0; i < M; i++)
	{
		int WPL = 0;
		for (int j = 0; j < N; j++)
		{
			cin >> c[j] >> code[j];
			WPL += w[j] * (int)strlen(code[j]);
		}
		if (WPL > minWPL)
		{
			//cout << "No" << endl;
			 cout << "Yes" << endl;
			//cout << "WPL=" << WPL << endl;
		}
		else
		{
			bool flag = false;
			for (int m = 0; m < N - 1; m++)
			{
				for (int l = m+1; l < N; l++)
				{
					int mincode = (int)(strlen(code[m]) > strlen(code[l]) ? strlen(code[l]) : strlen(code[m]));
					if (strncmp(code[m], code[l], mincode) == 0)
					{
						cout << "No" << endl;
						flag = true;
						break;
					}
				}
				if (flag)
					break;
			}
			if (!flag)
				cout << "Yes" << endl;
		}
		for (int i = 0; i < N; i++)
		{
			memset(code[i], 0, sizeof(code[i]));
		}
	}
	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值