PAT A1025 PAT Ranking (25 分)的简单写法

原题
Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

题目解释:关于pat的双重排序,分数一样按照id由小到大排列,不一样按照分数进行全局的排列以及组内排列。
首先建立结构体,然后写一个cmp的双重排序,由于使双重排序,所以用?:运算符,直接return。
下面是AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
struct student{
	char id[20];
	int score,global_rank,loc_rank,group;
}stu[300005];
bool cmp(student a,student b){
	return (a.score==b.score)?strcmp(a.id,b.id)<0:a.score>b.score;
}
int main(){
	int n,k,sum=0;
	scanf("%d",&n);
	for(int i=1;i<=n;i++){
		scanf("%d",&k);
		sum+=k;
		for(int j=sum-k;j<sum;j++){
			scanf("%s%d",stu[j].id,&stu[j].score);
			stu[j].group=i;
		}
		sort(stu+sum-k,stu+sum,cmp);
		stu[sum-k].loc_rank=1;
		for(int p=sum-k+1;p<sum;p++){
			if(stu[p].score==stu[p-1].score)
			    stu[p].loc_rank=stu[p-1].loc_rank;
			else{
				stu[p].loc_rank=p-(sum-k)+1;
			}
		}
	}
	printf("%d\n",sum);
	sort(stu,stu+sum,cmp);
	stu[0].global_rank=1;
	printf("%s %d %d %d\n",stu[0].id,stu[0].global_rank,stu[0].group,stu[0].loc_rank);
	for(int i=1;i<sum;i++){
	    if(stu[i].score==stu[i-1].score)
		    stu[i].global_rank=stu[i-1].global_rank;
		else{
			stu[i].global_rank=i+1;
		}	
		printf("%s %d %d %d\n",stu[i].id,stu[i].global_rank,stu[i].group,stu[i].loc_rank); 
	}
	
	return 0;
}

注意:如果第四个测试点出现段错误,可能是学生数组不够大,建议建立数组的时候拉大一点。
在这里插入图片描述

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值