【PAT】甲级 A1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

代码如下:

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;

struct testee{
	char id[13];
	int score;
	int final_rank;
	int local_rank;
	int location_number;
}testees[30010];
bool cmp(testee a,testee b){
	if(a.score!=b.score)
		return a.score>b.score;
	else
		return strcmp(a.id,b.id)<0;
}
int main(){
	int n,m,total=0;//区域数,区域内考生数,总考生数 
	cin>>n;
	int i;
	for(i=0;i<n;i++){
		cin>>m;
		int j;
		for(j=total;j<total+m;j++){//注意循环的起止点 
			cin>>testees[j].id>>testees[j].score;
			testees[j].location_number=i+1;
		}
		sort(testees+total,testees+total+m,cmp);
		for(j=total;j<total+m;j++){
			if(j>total&&testees[j].score==testees[j-1].score)
				testees[j].local_rank=testees[j-1].local_rank;
			else
				testees[j].local_rank=j-total+1;//注意j并非从0开始所以要减去total 
		}
		total+=m;
	}
	sort(testees,testees+total,cmp);
	int j;
	for(j=0;j<total;j++){
		if(j>0&&testees[j].score==testees[j-1].score)
			testees[j].final_rank=testees[j-1].final_rank;
		else
			testees[j].final_rank=j+1;
	}
	cout<<total<<endl;
	for(j=0;j<total;j++)
		cout<<testees[j].id<<" "<<testees[j].final_rank<<" "<< testees[j].location_number<<" "<< testees[j].local_rank<<endl;
	return 0;
} 

遇到问题

我在第一次提交代码时出现了第3个测试点不通过的情况,这是由于我将id设为了long long类型,存在00…00X这种id格式,前面的0无法得到输出。测试点3未通过
改为使用char类型后错误得到解决:
改用char类型表示序号后通过啦!

以后也长个记性,遇到这种很长的序号可以优先考虑用char类型而非long long。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值