PAT甲级1077 Kuchiguse (20 分)

1077 Kuchiguse (20 分)

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)

  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

结尾无空行

Sample Output 1:

nyan~

结尾无空行

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

结尾无空行

Sample Output 2:

nai

结尾无空行

说的那么复杂,其实就是求所有字符串最长公共后缀而已(((┏(; ̄▽ ̄)┛

#include <iostream>
#include <vector>
using namespace std;

int main()
{
    int n;
    cin>>n;
    cin.ignore();
    vector<string> vec;
    int len=0;
    for(int i=0;i<n;i++)
    {
        string sentence;
        getline(cin,sentence);
        vec.push_back(sentence);
        if(sentence.size()>len)
        {
            len=sentence.size();
        }
    }
    for(int i=0;i<vec.size();i++)
    {
        if(vec[i].size()<len)
        {
            int dif=len-vec[i].size();
            for(int j=0;j<dif;j++)
            {
                vec[i]=" "+vec[i];
            }
        }
    }
    int pos=len-1;
    bool flag=true;
    while(pos>=0&&flag)
    {
        char c=vec[0][pos];
        for(int i=1;i<vec.size();i++)
        {
            if(vec[i][pos]!=c)
            {
                flag=false;
                break;
            }
        }
        if(flag)
            pos--;
    }
    if(pos==len-1)
        cout<<"nai"<<endl;
    else
        cout<<vec[0].substr(pos+1)<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值