PAT甲级1085 Perfect Sequence (25 分)

该博客介绍了一种算法问题,即在给定正整数序列和一个参数p的情况下,找出能形成完美子序列的最大数量的元素。完美子序列的条件是序列中最大值不超过最小值与p的乘积。提供的C++代码实现了这一算法,通过排序和双指针遍历找到满足条件的最长子序列长度。
摘要由CSDN通过智能技术生成

1085 Perfect Sequence (25 分)

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤105) is the number of integers in the sequence, and p (≤109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

结尾无空行

Sample Output:

8

结尾无空行

是部分序列~不是一定要从最小开始~

乘积可能会溢出,所以要longlong~

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

int main()
{
    int len;
    long long p;
    cin>>len>>p;
    vector<long long> vec;
    for(int i=0;i<len;i++)
    {
        long long num;
        cin>>num;
        vec.push_back(num);
    }
    sort(vec.begin(),vec.end());
    int res=0;
    for(int i=0;i<len;i++)
    {
        int temp=0;
        for(int j=i+res;j<len;j++)
        {
            if(vec[j]<=vec[i]*p)
            {
                temp=j-i+1;
                if(temp>res)
                    res=temp;
            }
            else
                break;
        }
    }

    cout<<res<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值