4 Values whose Sum is 0

5 篇文章 0 订阅

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute
how many quadruplet (a, b, c, d) ∈ A × B × C × D are such that a + b + c + d = 0. In the following, we
assume that all lists have the same size n.
Input
The input begins with a single positive integer on a line by itself indicating the number of the cases
following, each of them as described below. This line is followed by a blank line, and there is also a
blank line between two consecutive inputs.
The first line of the input file contains the size of the lists n (this value can be as large as 4000).
We then have n lines containing four integer values (with absolute value as large as 228) that belong
respectively to A, B, C and D.
Output
For each test case, your program has to write the number quadruplets whose sum is zero.
The outputs of two consecutive cases will be separated by a blank line.
Sample Input
1
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output
5
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30),
(26, 30, -10, -46), (-32, 22, 56, -46), (-32, 30, -75, 77), (-32, -54, 56, 30).

本题最容易想到的算法是四重遍历,显然会超时,所以我们需要对算法进行优化

本题算法思想叫做中途相遇法,从问题的两个方向来解决问题,最后汇集一点。
例如双向bfs,从两侧来加速解决问题的速度,就像挖隧道,两侧一块动手,工期减半,所以这种思想常常用来优化算法

对于本题,优化从两方面考虑,第一:以已知变量代替未知变量,第二:以查找来代替遍历

我们可以选择容器map,也可以自己手写hash,存储A+B的值到map中,然后查询 -(c+d)的出现次数
因为 a+b+c+d为0,所以-(c+d)的出现次数便是答案,附上C++代码

#include <iostream>
#include <iomanip>
#include <string.h>
#include <cstdio>
#include <algorithm>
#include <bits/stdc++.h>
using namespace std;
const int maxn = 4005;
int A[maxn],B[maxn],C[maxn],D[maxn],sumAB[maxn];

int main()
{
    int T,n;
    cin>>T;
    for(int k = 0;k < T;k++)
    {
        if(k!=0)    puts("");
        cin>>n;
        for(int i = 0;i < n;i++)
        {
            cin>>A[i]>>B[i]>>C[i]>>D[i];
        }
        unordered_map<int,int> _map;
        for(int i = 0;i < n;i++)
            for(int j = 0;j < n;j++)
                _map[A[i]+B[j]]++;


        int ans = 0;
        for(int i = 0;i < n;i++)
            for(int j = 0;j < n;j++)
                ans += _map[-(C[i]+D[j])];
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值