HDU1548 A strange lift 奇怪的电梯(BFS+队列)

A strange lift

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button “UP” , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button “DOWN” , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can’t go up high than N,and can’t go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button “UP”, and you’ll go up to the 4 th floor,and if you press the button “DOWN”, the lift can’t do it, because it can’t go down to the -2 th floor,as you know ,the -2 th floor isn’t exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button “UP” or “DOWN”?
Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,…kn.
A single 0 indicate the end of the input.
Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can’t reach floor B,printf “-1”.
Sample Input
5 1 5
3 3 1 2 5
0
Sample Output
3

题意:
有一个特别的电梯,第i层有一个对应的数字ki, 对于第i层按上升键up可升上到i+k[i]层,按下降键down到达i-k[i]层,到达的楼层最高不能超过n层,最低不能小于1层。给你一个起点A和终点B,问最少要按几次上升键或者下降键到达目的地。

思路:
最短路:把每一层都看成一个节点,问题就可以变成求起点到终点的最短路径问题。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
#define maxn 10005
struct node
{
    int to,step;
}a,b;
int v[maxn],f[maxn];
int main()
{
    int cas,n,m,i;
    while(~scanf("%d",&cas)&&cas)
    {
        scanf("%d%d",&m,&n);
        memset(v,0,sizeof(v));
        for(i=1; i<=cas; i++)
            scanf("%d",&f[i]);//输入每层可以上下的层数
        queue<node>q;//定义队列
        while(!q.empty())
        {
            q.pop();
        }
        int  t1,t2,flag=0;
        a.step=0;//起始点
        a.to=m;
        q.push(a);
        v[a.to]=1;
        while(!q.empty())
        {
            a=q.front();//取出首元素
            q.pop();
            if(a.to == n)//如果到达终点
            {
                printf("%d\n",a.step);
                flag=1;
                break;
            }
            t1=a.to+f[a.to];//向上走
            if(t1<=cas&&!v[t1])
            {

                v[t1]=1;
                b.to=t1;
                b.step=a.step+1;
                q.push(b);
            }
            t1=a.to-f[a.to];//向下走
            if(t1>=1&&!v[t1])
            {
                v[t1]=1;
                b.to=t1;
                b.step=a.step+1;
                q.push(b);
            }
        }
        if(!flag)//如果走不到
            printf("-1\n");
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值