hdu 1503 Advanced Fruits

Advanced Fruits

The company “21st Century Fruits” has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn’t work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them.
A big topic of discussion inside the company is “How should the new creations be called?” A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn’t sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, “applear” contains “apple” and “pear” (APPLEar and apPlEAR), and there is no shorter string that has the same property.
A combination of a cranberry and a boysenberry would therefore be called a “boysecranberry” or a “craboysenberry”, for example.
Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names.
Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.
Input is terminated by end of file.
Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
Sample Input
apple peach
ananas banana
pear peach
Sample Output
appleach
bananas
pearch

题意:
给你两个字符串,要你用这两个字符串组成这样一个字符串,在组成的字符串中字符的相对顺序不变的情况下,可以在组成的字符串中找到原先两个字符串,字母可以错开,但是相对顺序不能变化,要这个组成的字符串中字母数最少,并输出这个字符串。

思路:
先找出两个字符串的公共子串,然后把剩下的字符加进去;
例子:apple peach
子串:pe
加入后:(a)p(pl)e(ach)

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
int dp[1005][1005],flag[1005][1005];
char a[1005],b[1005];
int main()
{
    int n;
    while(~scanf("%s%s",a,b))
    {
        memset(dp,0,sizeof(dp));
        memset(flag,0,sizeof(flag));
        int m = strlen(a);
        int n = strlen(b);
        int m1=m,n1=n;
        int i,j;
        for(i = 1; i <= m; i++) //第i个之前的最长公共子序列,所以要从1到m,不是0到m-1。
            for(j = 1; j <= n; j++) //第j个之前的最长公共子序列
            {
                if(a[i-1] == b[j-1])
                {
                    dp[i][j] = dp[i-1][j-1] + 1;
                    flag[i][j] = 1; //上一步(i-1,j-1),斜向左上
                }
                else if(dp[i-1][j] > dp[i][j-1])
                {

                    dp[i][j] = dp[i-1][j];
                    flag[i][j] = 2; //上一步(i-1,j),上方
                }
                else
                {

                    dp[i][j] = dp[i][j-1];
                    flag[i][j] = 3;//上一步(i,j-1),左方
                }
            }
        //如何构造最长公共子序列?
        int  k = 0;
        char c[1010];
        memset(c,0,sizeof(c));
        while(m > 0 && n > 0)//从终点按标记的方向反方向往回走
        {
            if(flag[m][n] == 1)  //这个方向来的元素包含在最长公共子序列中
            {
                c[k++] = a[m - 1];
                m--;
                n--;
            }
            else if(flag[m][n] == 2)
                m--;
            else if(flag[m][n] == 3)
                n--;
        }
        int p1=0,p2=0;
        for(i = k-1; i >= 0; i--)
        {
            while(a[p1]!=c[i]&&p1<m1)
            {
                printf("%c",a[p1]);
                p1++;
            }
            while(b[p2]!=c[i]&&p2<n1)
            {
                printf("%c",b[p2]);
                p2++;
            }
            printf("%c",c[i]);
            p1++,p2++;
        }
        while(a[p1]!=c[i]&&p1<m1)
        {
            printf("%c",a[p1]);
            p1++;
        }
        while(b[p2]!=c[i]&&p2<n1)
        {
            printf("%c",b[p2]);
            p2++;
        }
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值