POJ 3264 Balanced Lineup 区间查询(两棵树求最大最小值)

Balanced Lineup

For the daily milking, Farmer John’s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input
Line 1: Two space-separated integers, N and Q.
Lines 2… N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2… N+ Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output
Lines 1… Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input
6 3
1
7
3
4
2
5
1 5
4 6
2 2
Sample Output
6
3
0
题意:
给出n个奶牛和m次查询,n个奶牛的高度,查询[a,b]最大值-最小值
思路:
此题数据量非常大,简单的模拟必然会超时,线段树是个不错的选择,两个线段树分别查找最大值和最小值(不需要懒惰标记,蛮简单的)。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 200010
int sum[maxn],sum1[maxn];
int a[50010],b[50010];
void build(int x,int y,int o)
{
    if(x==y)
    {
        scanf("%d",&sum[o]);
        sum1[o]=sum[o];
        return ;
    }
    int mid=(x+y)>>1;
    build(x,mid,o<<1);
    build(mid+1,y,o<<1|1);
    sum[o]=max(sum[o<<1],sum[o<<1|1]);
    sum1[o]=min(sum1[o<<1],sum1[o<<1|1]);
}
//查找最大值
int queu(int a,int b,int n,int m,int o)
{
    if(a<=n&&b>=m)
        return sum[o];
    int mid=(n+m)>>1;
    int maxx=-1;
    if(mid>=a) maxx=queu(a,b,n,mid,o<<1);
    if(mid<b)  maxx=max(maxx,queu(a,b,mid+1,m,o<<1|1));
    return maxx;
}
//查找最小值
int quee(int a,int b,int n,int m,int o)
{
    if(a<=n&&b>=m)
        return sum1[o];
    int mid=(n+m)>>1;
    int minn=0x3f3f3f3f;
    if(mid>=a) minn=quee(a,b,n,mid,o<<1);
    if(mid<b)  minn=min(minn,quee(a,b,mid+1,m,o<<1|1));
    return minn;
}
int main()
{
    int n,m,i,j;
    while(~scanf("%d%d",&n,&m)&&(n+m))
    {
        memset(sum,0,sizeof(sum));
        memset(sum1,0,sizeof(sum1));
        build(1,n,1);
        int a,b;
        while(m--)
        {
            scanf("%d%d",&a,&b);
            if(a==b)
                printf("0\n");
            else
            {
                int t1=queu(a,b,1,n,1);
                int t2=quee(a,b,1,n,1);
                int t=t1-t2;
                printf("%d\n",t);
               // printf("%d\n",t2);
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值