LightOJ 1282 - Leading and Trailing (求n^k的前三位和后三位)

Leading and Trailing

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output
For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input
5
123456 1
123456 2
2 31
2 32
29 8751919
Sample Output
Case 1: 123 456
Case 2: 152 936
Case 3: 214 648
Case 4: 429 296
Case 5: 665 669

题意:
n^k的前三位和后三位。
思路:
思路:后三位快速幂就行了,关键是这个前三位。
任何一个数都可以用10^ n(n属于实数)来表示,先说一下怎么求n^k的前三位。
我先设10^ p=n^ k,同时取log10,那么p=klog10(n)。再设x=(int)p(整数部分),y=p-x(小数部分),那么10^ p=10^ x10^ y;由于10^ x是10的倍数,那么10^ y=n^ k/10^ x,就是n^ k的值,不过就是小数点位置不同。那么只要求得y就能知道前三位的值了。
计算方法:
double p=k*log10(n);
p=p-(int)p;
int ans=(int)(pow(10,p)*100);
这就是前三位。
(高中对数没学精,这题卡了好久,看了别人写的博客才知道是这么写的)

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define mod 1000
int pow_mod(int a,int n)
{
    if(n==1)return a%mod;
    ll t=pow_mod(a,n/2);
    ll ans=t*t%mod;
    if(n%2==1)ans=ans*a%mod;
    return ans;
}
int main()
{
    int T,k,n,f=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&k);
        double u=k*log10(n);
        double x=pow(10.0,u-(int)u);//前三位
        int y=pow_mod(n,k);//后三位
        printf("Case %d: %d %03d\n",f++,(int)(x*100),y);//别忘*100
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值