LightOJ 1282 - Leading and Trailing (求n^k的前三位和后三位)

Leading and Trailing

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output
For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input
5
123456 1
123456 2
2 31
2 32
29 8751919
Sample Output
Case 1: 123 456
Case 2: 152 936
Case 3: 214 648
Case 4: 429 296
Case 5: 665 669

题意:
n^k的前三位和后三位。
思路:
思路:后三位快速幂就行了,关键是这个前三位。
任何一个数都可以用10^ n(n属于实数)来表示,先说一下怎么求n^k的前三位。
我先设10^ p=n^ k,同时取log10,那么p=klog10(n)。再设x=(int)p(整数部分),y=p-x(小数部分),那么10^ p=10^ x10^ y;由于10^ x是10的倍数,那么10^ y=n^ k/10^ x,就是n^ k的值,不过就是小数点位置不同。那么只要求得y就能知道前三位的值了。
计算方法:
double p=k*log10(n);
p=p-(int)p;
int ans=(int)(pow(10,p)*100);
这就是前三位。
(高中对数没学精,这题卡了好久,看了别人写的博客才知道是这么写的)

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define mod 1000
int pow_mod(int a,int n)
{
    if(n==1)return a%mod;
    ll t=pow_mod(a,n/2);
    ll ans=t*t%mod;
    if(n%2==1)ans=ans*a%mod;
    return ans;
}
int main()
{
    int T,k,n,f=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&k);
        double u=k*log10(n);
        double x=pow(10.0,u-(int)u);//前三位
        int y=pow_mod(n,k);//后三位
        printf("Case %d: %d %03d\n",f++,(int)(x*100),y);//别忘*100
    }
}
CCF大数据与计算智能大赛-面向电信行业存量用户的智能套餐个性化匹配模型联通赛-复赛第二名-【多分类,embedding】.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值