1065 A+B and C (64bit) (20point(s))

1065 A+B and C (64bit) (20point(s))
Given three integers A, B and C in [−2^63​​ ,2^63], you are supposed to tell whether A+B>C.

Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:
For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false

long long 的范围为[−2^63​​ ,2^63-1]很明显直接使用使用long long不能解决问题
理论上应该使用大整数,但是由于一开始测试用例中没有2^63,故可以判断。
不知为何使用cin不能通过
若测试用例继续增大就只能用大整数了
自己的代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    long long a,b,c;
    cin>>n;
    bool flag=false;
    for(int i=1;i<=n;++i){
       scanf("%lld %lld %lld",&a,&b,&c);
        flag=false;
        if(a>0&&b>0){
            if(c>0){
                if(a>c-b){
                    flag=1;
                }
            }
            else if(c<=0){
                flag=1;
            }
        }
        else if(a<0&&b<0){
            if(c<0){
                if(a>c-b){
                    flag=1;
                }
            }
            else if(c>=0){
                flag=0;
            }
        }
        else{
            if(a+b>c)
                flag=1;
        }
        cout<<"Case #"<<i<<": ";
        if(flag==0)
            cout<<"false"<<endl;
        else
            cout<<"true"<<endl;
    }    
}

柳神的思路:利用正溢出会变负数,负溢出会变整数

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    long long a,b,c;
    cin>>n;
    for(int i=1;i<=n;++i){
        bool flag=false;
        scanf("%lld %lld %lld",&a,&b,&c);
        long long res=a+b;
        if(a>0&&b>0&&res<0)
            flag=true;
        else if(a<0&&b<0&&res>=0)
            flag=false;
        else if(res>c)
            flag=true;
        else
            flag=false;
        cout<<"Case #"<<i<<": ";
        if(flag==0)
            cout<<"false"<<endl;
        else
            cout<<"true"<<endl;
    }   
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值