It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city
1
-city
2
and city
1
-city
3
. Then if city
1
is occupied by the enemy, we must have 1 highway repaired, that is the highway city
2
-city
3
.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.
Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input:
3 2 3
1 2
1 3
1 2 3
Sample Output:
1
0
0
邻接表DFS,求连通块的数量,需要添加的数量为其-1
此题与深度无关,可以删去
#include<bits/stdc++.h>
using namespace std;
const int maxv=1010;
int n,m,k;
int currentPoint;
vector<int> Adj[maxv];
bool vis[maxv];
void DFS(int u,int depth){
if(u==currentPoint) return;
vis[u]=true;
for(int i=0;i<Adj[u].size();++i){
if(!vis[Adj[u][i]]){
DFS(Adj[u][i],depth+1);
}
}
}
int dfsTrave(){
int block=0;
memset(vis,false,sizeof(vis));
for(int u=1;u<=n;++u){
if(!vis[u]&&u!=currentPoint){
DFS(u,1);
block++;
}
}
return block;
}
int main(){
scanf("%d%d%d",&n,&m,&k);
int a,b;
for(int i=0;i<m;++i){
scanf("%d%d",&a,&b);
Adj[a].push_back(b);
Adj[b].push_back(a);
}
for(int i=0;i<k;++i){
scanf("%d",¤tPoint);
printf("%d\n",dfsTrave()-1);
}
}
并查集
#include<bits/stdc++.h>
using namespace std;
const int maxv=1010;
int n,m,k;
int currentPoint;
vector<int> Adj[maxv];
bool vis[maxv];
int father[maxv];
int findFather(int x){
int a=x;
while(x!=father[x]) x=father[x];
while(a!=father[a]){
father[a]=x;
a=father[a];
}
return x;
}
void Union(int a,int b){
int faA=findFather(a);
int faB=findFather(b);
if(faA!=faB) father[faA]=faB;
}
void init(){
for(int i=1;i<=n;++i){
father[i]=i;
vis[i]=false;
}
}
int main(){
scanf("%d%d%d",&n,&m,&k);
int a,b;
for(int i=0;i<m;++i){
scanf("%d%d",&a,&b);
Adj[a].push_back(b);
Adj[b].push_back(a);
}
for(int query=0;query<k;++query){
scanf("%d",¤tPoint);
init();
for(int i=1;i<=n;++i)
for(int j=0;j<Adj[i].size();++j){
int u=i,v=Adj[i][j];
if(u==currentPoint||v==currentPoint) continue;
Union(u,v);
}
int block=0;
for(int u=1;u<=n;++u){
if(u!=currentPoint){
int faU=findFather(u);
if(!vis[faU]){
vis[faU]=true;
block++;
}
}
}
printf("%d\n",block-1);
}
}