数据结构——栈和队列

模拟一个栈(使用数组模拟)

在这里插入图片描述
在这里插入图片描述

#include<iostream>
using namespace std;
const int N = 100010;

int stack[N];
int top;
void push(int x)
{
    stack[++top] = x;
}
void pop()
{
    top--;
}
bool if_empty()
{
    if(top>0) return false;
    else return true;
}
int query()
{
    return stack[top];
}

int main()
{
    int m;
    cin>>m;
    while(m--){
        string op;
        cin>>op;
        if(op=="push"){
            int x;
            cin >> x;
            push(x);
        }
        if(op=="query") cout<<query()<<endl;
        if(op=="pop") pop();
        if(op=="empty"){
            if(if_empty()) cout<<"Yes"<<endl;
            else cout<<"NO"<<endl;
        }
    }
    return 0;
}

队列

使用数组模拟一个队列

实现一个队列,队列初始为空,支持四种操作:

(1) “push x” – 向队尾插入一个数x;

(2) “pop” – 从队头弹出一个数;

(3) “empty” – 判断队列是否为空;

(4) “query” – 查询队头元素。

现在要对队列进行M个操作,其中的每个操作3和操作4都要输出相应的结果。

输入格式
第一行包含整数M,表示操作次数。

接下来M行,每行包含一个操作命令,操作命令为”push x”,”pop”,”empty”,”query”中的一种。

输出格式
对于每个”empty”和”query”操作都要输出一个查询结果,每个结果占一行。

其中,”empty”操作的查询结果为“YES”或“NO”,”query”操作的查询结果为一个整数,表示队头元素的值。

数据范围
1≤M≤100000,
1≤x≤109,
所有操作保证合法。

输入样例:
10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6
输出样例:
NO
6
YES
4

#include<iostream>
using namespace std;

const int N = 100010;
int queue[N];

int head,tail = -1;

void push(int x)
{
    tail++;
    queue[tail] = x;
}
bool if_empty()
{
    if(head>tail) return true;
    else return false;
}
void pop()
{
    head++;
}
int query()
{
    return queue[head];
}

int main()
{
    int m;
    cin>>m;
    while(m--)
    {
        string op;
        cin>>op;
        if(op=="push"){
            int x;
            cin>>x;
            push(x);
        }
        if(op=="pop") pop();
        if(op=="query") cout<<query()<<endl;
        if(op=="empty"){
            if(if_empty()) cout<<"YES"<<endl;
            else cout<<"NO"<<endl;
        }
    }
    return 0;
}

单调队列

一般用于求滑动窗口里面的最大值或者最小值
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述

#include <iostream>

using namespace std;

const int N = 1000010;

int a[N], q[N];

int main()
{
    int n, k;
    scanf("%d%d", &n, &k);
    for (int i = 0; i < n; i ++ ) scanf("%d", &a[i]);

    int hh = 0, tt = -1;
    for (int i = 0; i < n; i ++ )
    {
        if (hh <= tt && i - k + 1 > q[hh]) hh ++ ;

        while (hh <= tt && a[q[tt]] >= a[i]) tt -- ;
        q[ ++ tt] = i;

        if (i >= k - 1) printf("%d ", a[q[hh]]);
    }

    puts("");

    hh = 0, tt = -1;
    for (int i = 0; i < n; i ++ )
    {
        if (hh <= tt && i - k + 1 > q[hh]) hh ++ ;

        while (hh <= tt && a[q[tt]] <= a[i]) tt -- ;
        q[ ++ tt] = i;

        if (i >= k - 1) printf("%d ", a[q[hh]]);
    }

    puts("");

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

新城里的旧少年^_^

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值