HDU 1043 Eight

Eight

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Special Judge

Problem Description

The 15-puzzle has been around for over 100 years; even if you don’t know it by that name, you’ve seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let’s call the missing tile ‘x’; the object of the puzzle is to arrange the tiles so that they are ordered as:

1 2 3 4 5 6 7 8 9 10 11 1213 14 15 x

where the only legal operation is to exchange ‘x’ with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:

1 2 3 4 1 2 3 4 1 2 3 4 1 2 3 4 5 6 7 8 5 6 7 8 5 6 7 8 5 6 7 8 9 x 10 12 9 10 x 12 9 10 11 12 9 10 11 1213 14 11 15 13 14 11 15 13 14 x 15 13 14 15 x r-> d-> r->

The letters in the previous row indicate which neighbor of the ‘x’ tile is swapped with the ‘x’ tile at each step; legal values are ‘r’,‘l’,‘u’ and ‘d’, for right, left, up, and down, respectively.

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing ‘x’ tile, of course).

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.

Input

You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus ‘x’. For example, this puzzle

1 2 3
x 4 6
7 5 8

is described by this list:

1 2 3 x 4 6 7 5 8

Output

You will print to standard output either the word ``unsolvable’’, if the puzzle has no solution, or a string consisting entirely of the letters ‘r’, ‘l’, ‘u’ and ‘d’ that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.

Sample Input

2 3 4 1 5 x 7 6 8

Sample Output

ullddrurdllurdruldr

题意:

题目让我们求将123456789x变成给定输出的走的路。

思路:

八数码问题,本题是将所有情况打表反向搜索,因为如果是正向的话会超时,而反向打表的话就会内存超限,所有就必须数组的最大长度370000就够了,然后就是用语言c++,g++也会超内存,八9数码的话,本质就是一个bfs然后配合康托展开(可以百度百度,不难理解)记录所有的状态,这样也就可以把所有的路也记录下来了。

#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn = 370000;
int fac[20] = {1, 1, 2, 6, 24, 120, 720, 5040, 40320, 362880};
string pathn[maxn];
int cantor(int *a) {
    int sum = 0;
    for (int i = 0; i < 9; i++) {
        int num = 0;
        for (int j = i + 1; j < 9; j++) {
            if (a[i] > a[j]) num++;
        }
        sum += (num * fac[9 - i - 1]);
    }
    return sum + 1;
}
struct NODE {
    int loc;
    int s[9];
    int status;
    string path;
};
int aim = 46234;
char indexs[5] = "durl";
int Next[4][2] = {-1, 0, 1, 0, 0, -1, 0, 1};
bool book[maxn] = {false};
void bfs() {
    memset(book, false, sizeof(book));
    queue<NODE> q;
    NODE cur, nextn;
    for (int i = 0; i < 8; i++) cur.s[i] = i + 1;
    cur.s[8] = 0;
    cur.loc = 8;
    cur.status = aim;
    cur.path = "";
    q.push(cur);
    pathn[aim] = "";
    while (!q.empty()) {
        cur = q.front();
        q.pop();
        int x = cur.loc / 3;
        int y = cur.loc % 3;
        for (int i = 0; i < 4; i++) {
            int tx = x + Next[i][0];
            int ty = y + Next[i][1];
            if (tx < 0 || tx > 2 || ty < 0 || ty > 2) continue;
            nextn = cur;
            nextn.loc = tx * 3 + ty;
            nextn.s[cur.loc] = nextn.s[nextn.loc];
            nextn.s[nextn.loc] = 0;
            nextn.status = cantor(nextn.s);
            if (book[nextn.status] == false) {
                book[nextn.status] = true;
                nextn.path = indexs[i] + nextn.path;
                pathn[nextn.status] = nextn.path;
                q.push(nextn);
            }
        }
    }
}
int main() {
    char c;
    int a[10] = {0};
    bfs();
    while (cin >> c) {
        if (c == 'x') {
            a[0] = 0;
        } else a[0] = c - '0';
        for (int i = 1; i < 9; i++) {
            cin >> c;
            if (c == 'x') a[i] = 0;
            else a[i] = c - '0';
        }
        int x = cantor(a);
        if (book[x]) {
            cout << pathn[x] << endl;
        } else cout << "unsolved" << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值