POJ 2976 Dropping tests

Dropping tests

Time Limit: 1000MS Memory Limit: 65536K

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be
在这里插入图片描述
.
Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

思路:

二分中最大化平均值的模板题,主要的就是找到要输出的那个最大化的值,在找寻的途中,要使值越大,那么分子则越大,分母则越小,比如(a + b) / (c + d) = e,而e是需要求出来的值,这个时候(a + b = e * c + e * d),所以有(a - e * c + b - e * d)是否大于零,大于的话,肯定e就越大,所以要使(a - e * c)这样的越大,就将这些存到数组,然后排序。说说这一题自己最花时间的时间在舍弃的一列的可以为0的,因为题目说最后输入的第一行都为0的时候终止,就误导我了,然后就变成了n != 0 && m != 0这就是错的,实际上只要n != 0就行了的。

#include <iostream>
#include <algorithm>
using namespace std;
const float eps = 1e-7;
int n, m;
double up[1010], down[1010];
double check(double x) {
	double sum = 0;
	double a[1010];
	for (int i = 0; i < n; i++) {
		a[i] = up[i] - x * down[i];
	}
	sort(a, a + n);
	for (int i = m; i < n; i++) {
		sum += a[i];
	}
	return sum;
}
int main() {
	while (scanf("%d %d", &n, &m) != EOF && n != 0) {
		for (int i = 0; i < n; i++) scanf("%lf", &up[i]);
		for (int i = 0; i < n; i++) scanf("%lf", &down[i]);
		double l = 0.0, r = 1.0;
		while (r - l > eps) {
			double mid = (l + r) / 2;
			if (check(mid) < 0) r = mid;
			else l = mid;
		}	
		cout << (int)(r * 100 + 0.5) << endl;
	}
	return 0;
} 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值