POJ 3104 Drying

Drying

Time Limit: 2000MS Memory Limit: 65536K

Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2

思路:

二分来做,首先题目每分钟都要烘干1的水,因为是二分枚举时间来判断,所以先假设二分的时间为x,那么除去自然烘干的时间
要减去x,之后就是计算烘干机的时间,题目这个一分钟减少k所以就是烘干机加上自然烘干为k,而烘干机就是k-1最后所求的烘干机的时间就是(a[i] - x) / (k - 1)的时间,看看最后使用烘干机的时间会不会超过x就行了,假如烘干的时间为1的时候也就是只有自然烘干了,那么最后为多少就烘干多久。

#include <iostream>
#include <cmath>
using namespace std;
int n, m, sum = 0;;
int a[100010];
int check(int x) {
	int sum = x;
	for (int i = 0; i < n; i++) {
		if (a[i] - x > 0) {
			sum -= ceil((a[i] - x) * 1.0 / (m - 1));
		}
	}
	return sum;
}
int main() {
	int maxn = 0;
	scanf("%d", &n);
	for (int i = 0; i < n; i++) {
		scanf("%d", &a[i]);
		maxn = max(maxn, a[i]);
	} 
	scanf("%d", &m);
	if (m == 1) {
		cout << maxn << endl;
		return 0;
	}
	int l = 0, r = maxn;
	while (r - l > 1) {
		int mid = (l + r) >> 1;
		if (check(mid) >= 0) r = mid;
		else l = mid; 
		
	}
	cout << r << endl;
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值