POJ3104Drying (二分法的应用)

                                                            Drying

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2

 言归正传,我们首先来说一下这道题目的题意吧:

这是一道干衣服的题目,题目首先要我们输入的就是一个n和一个k,n指的是衣服的件数,k指的是机器一分钟能弄掉多少的水量,接下来一行就是每一件衣服上所含的水量,而面对这种这种二分问题的时候,我们要先想到对什么进行二分,在这道题目中无疑是对时间进行二分。

好接下来讲思路:老规矩,二分题,先定义一个模板二分bool函数,设这两段时间分别是x1和x2,那么有mid=x1+x2,ai<=k*x1+x2,解得x1>=(ai-mid)/(k-1) ,所以对(ai-mid)/(k-1)向上取整就是该件衣服的最少用时。这个是本道题的核心想法,如果题目做的不够多的话,挺难想到的。模板函数里面实际上也就是定义了一个时间的关系。

接下来说一下主函数的思路构建吧,先把几件衣服都 输入进来,然后把每一件衣服的含水量也都输入进来,然后立刻引入bool函数进行求解,把结果输出一下就可以了。

接下来上代码:

/*****************************
这道题的具体思路就是: 
设某次二分出的一个值是mid:
1、对于一件a[i]值小于等于mid的衣服,直接晾干即可;
2、对于一件a[i]值大于mid值的衣服,最少的用时是用机器一段时间,晾干一段时间,设这两段时间分别是x1
和x2,那么有mid=x1+x2,ai<=k*x1+x2,解得x1>=(ai-mid)/(k-1) ,所以对(ai-mid)/(k-1)向上取整就是
该件衣服的最少用时。
******************************/
#include<bits/stdc++.h>
long long n,k;//n表示n件有水的衣服,k表示机器一分钟能够去掉多少水 
long long a[100010];//用来存储n件衣服上的水量,这道题的数据都要用long long类型,不然会wa报错 
bool dix(long long x)//此处的x为主函数的mid 
{
	long long i,time=0;
	if(k==1)//注意判断k是否为1,为1在下面会除以0,提交会RE ,这一部很容易忘记
		return true;
	for(i=0;i<n;++i)
	{
		if(a[i]>x)//如果找到一件衣服的水量比平均值大的话 
		{
			time+=(a[i]-x+k-1.8)/(k-1);//用向上取整函数ceil会WA,这里用K-2来向上取整
		}
	}
	return time>x;
}
int main()
{
	long long max;
	long long i;
	while(scanf("%lld",&n)!=EOF)
	{
		max=0;
		for(i=0;i<n;++i)
		{
			scanf("%lld",&a[i]);//把每一件衣服的含水量输进来 
			if(max<a[i])//挑选出含水量最大的衣服
				max=a[i];
		}
		scanf("%lld",&k);//输入机器一分干燥的水量 
		long long left=0,right=max,mid;
		while(left<right-1)//循环条件 
		{
			mid=(left+right)/2;
			if(dix(mid))
				left=mid;
			else
				right=mid;
		}
		printf("%lld\n",right);//在这道题中right实际上就是题目所要求的时间
	}
	return 0;
}

这道题也属于二分的经典题目,有兴趣的同学也可以继续来研究。

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值