POJ 2836 Rectangular Covering

Rectangular Covering

Time Limit: 1000MS Memory Limit: 65536K

Description

n points are given on the Cartesian plane. Now you have to use some rectangles whose sides are parallel to the axes to cover them. Every point must be covered. And a point can be covered by several rectangles. Each rectangle should cover at least two points including those that fall on its border. Rectangles should have integral dimensions. Degenerate cases (rectangles with zero area) are not allowed. How will you choose the rectangles so as to minimize the total area of them?

Input

The input consists of several test cases. Each test cases begins with a line containing a single integer n (2 ≤ n ≤ 15). Each of the next n lines contains two integers x, y (−1,000 ≤ x, y ≤ 1,000) giving the coordinates of a point. It is assumed that no two points are the same as each other. A single zero follows the last test case.

Output

Output the minimum total area of rectangles on a separate line for each test case.

Sample Input

2
0 1
1 0
0

Sample Output

1

Hint

The total area is calculated by adding up the areas of rectangles used.

思路:

状态压缩,首先就是算矩形,假如某个点在某个矩形里面那就加入这个集合里面就行了,因为每个矩形必有两点,所以就用了双重循环,把所有可能的情况都写出来,然后用动态规划做出来。不难,看完代码就很容易理解了。

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
using namespace std;
const int maxn = 16;
const int inf = 0x7fffffff;
struct NODE {
	int area;
	int s;
};
NODE node[1 << maxn];
int dp[1 << maxn], x[maxn], y[maxn];
int main() {
	int n;
	while (scanf("%d", &n) != EOF && n) {
		int t = 0;
		for (int i = 0; i < n; i++) scanf("%d %d", &x[i], &y[i]);
		for (int i = 0; i < n - 1; i++) {
			for (int j = i + 1; j < n; j++) {
				node[t].area = max(1, abs(x[i] - x[j])) * max(1, abs(y[i] - y[j]));
				node[t].s = (1 << i) | (1 << j);
				for (int k = 0; k < n; k++) {
					if ((x[k] - x[i]) * (x[k] - x[j]) <= 0 && (y[k] - y[i]) * (y[k] - y[j]) <= 0) {
						node[t].s |= 1 << k;
					}
				}
				t++;
			}
		}
		fill(dp, dp + (1 << maxn), inf);
		dp[0] = 0;
		for (int i = 0; i < t; i++) {
			for (int j = 0; j < 1 << n; j++) {
				int m = node[i].s | j;
				if (dp[j] != inf && m != j) dp[m] = min(dp[m], dp[j] + node[i].area);
			}
		}
		printf("%d\n", dp[(1 << n) - 1]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值