POJ 3670 Eating Together

Eating Together

Time Limit: 1000MS Memory Limit: 65536K

Description

The cows are so very silly about their dinner partners. They have organized themselves into three groups (conveniently numbered 1, 2, and 3) that insist upon dining together. The trouble starts when they line up at the barn to enter the feeding area.

Each cow i carries with her a small card upon which is engraved Di (1 ≤ Di ≤ 3) indicating her dining group membership. The entire set of N (1 ≤ N ≤ 30,000) cows has lined up for dinner but it’s easy for anyone to see that they are not grouped by their dinner-partner cards.

FJ’s job is not so difficult. He just walks down the line of cows changing their dinner partner assignment by marking out the old number and writing in a new one. By doing so, he creates groups of cows like 111222333 or 333222111 where the cows’ dining groups are sorted in either ascending or descending order by their dinner cards.

FJ is just as lazy as the next fellow. He’s curious: what is the absolute mminimum number of cards he must change to create a proper grouping of dining partners? He must only change card numbers and must not rearrange the cows standing in line.

Input

  • Line 1: A single integer: N
  • Lines 2…N+1: Line i describes the i-th cow’s current dining group with a single integer: Di

Output

  • Line 1: A single integer representing the minimum number of changes that must be made so that the final sequence of cows is sorted in either ascending or descending order

Sample Input

5
1
3
2
1
1

Sample Output

1

思路:

最长不下降子序列和最长不上升子序列去最小,最长不上升子序列就是最长不下降子序列的循环相反就行了,反方向的递增不就是正方向的递减吗。

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
const int maxn = 3e+4 + 10;
const int inf = 0x7fffffff;
int main() {
    int n;
    int a[maxn] = {0}, dp[maxn], dpn[maxn];
    scanf("%d", &n);
    for (int i = 0; i < n; i++) scanf("%d", &a[i]);
    fill(dp, dp + n, inf);
    fill(dpn, dpn + n, inf);
    for (int i = 0; i < n; i++) {
        *upper_bound(dp, dp + n, a[i]) = a[i];
    }
    for (int i = n - 1; i >= 0; i--) {
        *upper_bound(dpn, dpn + n, a[i]) = a[i];
    }
    int Min = min(n - (lower_bound(dp, dp + n, inf) - dp), n - (lower_bound(dpn, dpn + n, inf) - dpn));
    printf("%d", Min);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值