PAT练习题(甲级) 1001 A+B Format

PAT练习题 1001 A+B Format

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤10​6. The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9

Sample Output:
-999,991

题意

实现a+b,将结果进行标准化输出——从最后三位开始,每三位用“,”进行分隔。a和b的范围题目中已经给了。
输入格式:a空格b
输出格式:标准化结果

解题关键

  • 这道题比较简单,利用C进行编程会提高解题速度
  • 输入a和b,进行加法运算
  • 关键的操作就是对结果的转化

代码思路和分析

  • 将sum的每位数字使用while循环存入数组(此处使用abs绝对值函数)
  • 根据数组的长度进行循环,每隔三位输出","即可

实现代码

#include<stdio.h>
#include<stdlib.h>
int main()
{
    int i,j,a,b,sum,num1,num2;
    int num[8];
    i = 0;
    scanf("%d%d",&a,&b);
    sum = a+b;
    if(sum<0)
        printf("-");
    if(sum==0)
    {
        printf("0");
        exit(0);
    }
    while(sum)
    {
        num[i] = abs(sum%10);
        i++;
        sum/=10;
    }
    for(j = i-1;j>=0;j--)
    {
        printf("%d",num[j]);
        if(j%3==0&&j!=0)
            printf(",");
    }
    return 0;
}

总结

这种方法也算是暴力解法,但在时间上的处理会更快一些,同时在测试的时候也可以减少这道题浪费的时间。

  • 5
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值