【C语言】PAT甲级训练题目 1032题总结

其他题目:【C语言】PAT甲级训练题目答案、知识点梳理及总结

链接:原题

原题内容:

1032 Sharing (25 分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

思路:

很简单的静态链表的题目,

其实根本不需要记录字符的值,根据范例2可得到,相同的字符a的节点也不同,如图的情况会不会发生,即是否存在节点共用,但是其实不是后缀的情况。

解决方案是把链表变成双向的,从后往前读取即可。

也通过了实验证明不是后缀的情况下,不存在共用节点的情况。

 

但是题目并没有强制规定,末尾一定指向NULL,也就是说末尾也可能是0,如果使用while循环,则要考虑这个因素,否则节点2会超时无法通过。

代码: 

#include<stdio.h>
#include<stdlib.h>
#include<algorithm>

struct node
{
//	int pre;
	int flag;
	int next;
}arr[100000];
int main()
{
	char c;
	int i, n, a, b, st, ed, sum = 0;
	scanf("%d %d %d", &a, &b, &n);
	for (i = 0; i < n; i++)
	{
		scanf("%d %c %d", &st, &c, &ed);
		arr[st].next = ed;
	}
	i = a;
	while (arr[i].next != -1)
	{
		arr[i].flag = 1;
		i = arr[i].next;
	}
	i = b;
	while (arr[i].next != -1 && arr[i].next != 0)
	{
		if (arr[i].flag == 1)
		{
			printf("%05d", i);
			return 0;
		}
		i = arr[i].next;
	}
	printf("%d", -1);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值