【蓝桥杯】算法提高 最大值路径

import java.util.Scanner;

public class 蓝桥杯_最大值路径 {
/*
样例输入
5
4 5 4 5 6
2 6 5 4 6
2 6 6 5 2
4 5 2 2 5
5 2 5 6 4
样例输出
3 47
 */
	static long res[]=new long[10000];
	static int data[][];
	static int n;
	static long ans;
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		n=sc.nextInt();
		data=new int[n][n];
		
		for(int i=0;i<n;i++){
			for(int j=0;j<n;j++){
				data[i][j]=sc.nextInt();
			}
		}
		
		ans=data[n-1][0];
		dfs(n-1,0,ans);
		int k=0;
		long max=0;
		for(int i=0;i<10000;i++){
			if(res[i]>0){
				max=res[i];
				k=i;
			}
		}
		
		System.out.print(res[k]+" "+k);
	}
	
	static void dfs(int x,int y,long ans){
		if(x==0 && y==n-1){
			res[(int) ans]+=1;
			return;
		}
		
		//上
		if(y==n-1 || x>0){
			ans+=data[x-1][y];
			dfs(x-1,y,ans);
			ans-=data[x-1][y];
		}
		
		//右
		if(x==0 || y<n-1){
			ans+=data[x][y+1];
			dfs(x,y+1,ans);
			ans-=data[x][y+1];
		}
	} 
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值