1064 Complete Binary Search Tree (30分)

Problem

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  1. The left subtree of a node contains only nodes with keys less than the node’s key.
  2. The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  3. Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.
Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input

10
1 2 3 4 5 6 7 8 9 0

Sample Output

6 3 8 1 5 7 9 0 2 4

解题思路

  1. 已知结点数目且为完全二叉树(CBT),因此想到改造层次遍历的代码,构造完全二叉树。
  2. 改造中序遍历的代码,完成二叉排序树。

Code

#include <stdio.h>
#include <stdlib.h>
int pos=0;			//填充二叉排序树时定位数组位置
typedef struct T	//二叉树结点定义
{
    int data;
    struct T *lchild;
    struct T *rchild;
}T;
int cmp(const void *p1,const void *p2)
{
    int *a=(int *)p1;
    int *b=(int *)p2;
    if(*a>*b)
        return 1;
    else return -1;
}
T *CreateCBT(int num)   //num为结点个数
{
    int cnt=1;
    T *root=(T *)malloc(sizeof(T));
    root->lchild=root->rchild=NULL;
    T **Queue=(T **)malloc(sizeof(T *)*(num+1));
    int front=0,rear=0;
    Queue[rear++]=root;
    while(front!=rear&&cnt<num)
    {
        T *pt=Queue[front++];
        if(cnt<num)     //设置左子树,如果左子树为空则不用设置,因为在上一次循环中已经定义为NULL
        {
            T *node=(T *)malloc(sizeof(T));
            node->lchild=node->rchild=NULL;
            pt->lchild=node;
            cnt++;			//记录已经读到几个非空节点,如果已经到达数量,则不会再新增结点
            Queue[rear++]=node;
        }
        if(cnt<num)     //设置右子树
        {
            T *node=(T *)malloc(sizeof(T));
            node->lchild=node->rchild=NULL;
            pt->rchild=node;
            cnt++;
            Queue[rear++]=node;
        }
    }
    return root;
}
void FillInOrder(T *root,int *arr)		//中序遍历填充排序二叉树
{
    if(root!=NULL)
    {
        FillInOrder(root->lchild,arr);
        root->data=arr[pos++];
        FillInOrder(root->rchild,arr);
    }
}
int main()
{
    int N;
    if(scanf("%d",&N)==1)
    {
        int *arr=(int *)malloc(sizeof(int)*N);
        for(int i=0;i<N;i++)
            scanf("%d",&arr[i]);
        qsort(arr,N,sizeof(int),cmp);
        T* root=CreateCBT(N);   //层次遍历构造完全二叉树
        FillInOrder(root,arr);
        T **Queue=(T **)malloc(sizeof(T *)*N);
        int front=0,rear=0;
        Queue[rear++]=root;
        int count=0;
        while(front!=rear)
        {
            T *qt=Queue[front++];
            if(qt->lchild!=NULL)
                Queue[rear++]=qt->lchild;
            if(qt->rchild!=NULL)
                Queue[rear++]=qt->rchild;
            printf("%d",qt->data);
            count++;
            if(count<N) printf(" ");
        }
    }
    return 0;
}

Result

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值