ng-zorro版本问题

现在,ng-zorro已经更新到10.0.2版本了,更新真是太快了
在这里插入图片描述
在版本上,我吃了好多亏

1、版本下载

下载的时候注意下载的版本 ,尽量不要下载最新版本
下载的时候注意下载的版本 ,尽量不要下载最新版本
下载的时候注意下载的版本 ,尽量不要下载最新版本
重要的事情说三遍
什么叫做不要下载最近版本?

// 这种方式下载的就是最新版本(默认的)
cnpm i ng-zorro-antd --save

下载的时候加上版本号,指定下载版本(我喜欢使用9.1.2或9.2.0版本的)

cnpm i ng-zorro-antd@9.2.0 --save

2、配置重启

2.1、下载完了要配置,配置后要重启。否则看不到zorro的效果
2.2、更新版本后也要重启(建议不要换版本,因为可能会出现不兼容)

3、展示版本与你使用的版本

就这个地方,我卡了好久
某个组件,我明明就是按官网的实例做的,每行代码都一样,可就是显示不出官网的效果
但其他的组件又正常显示
我去找我的配置文件、全局设置、npm的其他插件的影响等等
就是找不出问题所在
我当时都要崩溃了……
后来我问了别人,他说了句
在这里插入图片描述
我当时是这个表情
在这里插入图片描述
人家都说出问题所在了,我也不好意思继续问了,于是我就自己扣
我先更新我的zorro版本,于是冲突出现了,但不更新,我怎么使用呢?
过了一夜,今天又去官网逛逛,结果,有发现了,嘿嘿
我就大发慈悲的跟你们也说说,哈哈哈哈
在这里插入图片描述

在这里插入图片描述
选择与自己相同的版本,选择之后,zorro的官网也会发生变化,示例模板也会改变,问题就解决了。我也终于懂了我的错误所在。
在这里还要谢谢给我指明错误方向的人

©️2020 CSDN 皮肤主题: 游动-白 设计师:上身试试 返回首页