【 HDU - 1213 】 A - How Many Tables (简单并查集)求集合个数

本文介绍了一个解决生日派对中桌位安排问题的算法。通过建立朋友之间的关系图,利用并查集数据结构,算法能够快速计算出最少需要多少张桌子来满足所有朋友都不与陌生人同桌的需求。该算法适用于各种规模的派对,能够有效处理大量输入数据。
摘要由CSDN通过智能技术生成

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

代码:

#include <iostream>
#include <algorithm>
#include <vector>
#include <queue> 
#include <set>
#include <map>
using namespace std;
int t,n,m,a,b;
int father[1100];


int find(int x){  //路径压缩
	return x==father[x]?x:father[x]=find(father[x]);
}

void init() //初始化
{
	for(int i=1;i<=n;i++)
	   father[i]=i;
}

void Union(int a,int b) //合并
{
	int fa=find(a);
	int fb=find(b);
	if(fa!=fb)  father[fa]=fb;
}

int main()
{
	
	cin>>t;
	while(t--)
	{
		cin>>n>>m;
		init();
		while(m--)
		{
			cin>>a>>b;
			Union(a,b); 
		}
		int cnt=0;
		for(int i=1;i<=n;i++)
		   if(father[i]==i) cnt++;  //父亲就是自己:为祖先(一个集合)
		cout<<cnt<<endl;
	} 
    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值