E - How Many Tables(并查集 判断集合个数)

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2

5 3

1 2

2 3

4 5

 

5 1

2 5

Sample Output

2

4

  • 题意概括  :

生日聚会,如果有朋友互相认识,则分到一桌,如果不认识则分到其他桌,总之就是只要里面有认识的就坐在一个桌上,问需要分成几个桌。

  • 解题思路  :

找出一共有多少个父节点,父节点的个数即为所要分成的桌的个数。

#include<stdio.h>
#include<string.h>

int f[1010];
int n,m;

int getf(int v)
{
	if(f[v] != v)
	f[v] = getf(f[v]);
	return f[v];
}
int merge(int v,int u)
{
	int t1,t2;
	t1 = getf(v);
	t2 = getf(u);
	
	if(t1 != t2)
	{
		f[t2] = t1;
	}
}
int main()
{
	int T,i,j,sum,a,b;
	
	scanf("%d",&T);
	while(T --)
	{
		sum = 0;
		scanf("%d %d",&n,&m);
		
		for(i = 1;i<=n;i ++)
		{
			f[i] = i;
		}
		
		for(i = 1;i<=m;i ++)
		{
			scanf("%d %d",&a,&b);
			merge(a,b);
		}
		for(i = 1;i<=n;i ++)
		{
			if(f[i] == i)
			{
				sum ++;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值