【 POJ - 2236 】E - Wireless Network (并查集)

题目:

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:

  1. “O p” (1 <= p <= N), which means repairing computer p.
  2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

思路:

一开始想不到更好的方法,总觉得铁定超时,然后乍一看,这题时间限制10s,那还想啥,直接暴力比较就完事了

两点均开放 且距离小于d,就合并


代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std; 
const int maxn=1005;
bool open[maxn]={false}; //记录该点是否开放
int n,d,a,b,father[maxn];
char x;

struct node{ //位置
	int x,y;
}point[maxn];

int find(int x){  //找根,路径压缩
	return x==father[x]?x:father[x]=find(father[x]);
}

void init(){ //初始化
	for(int i=1;i<=n;i++) father[i]=i;
}

void Union(int a,int b) //合并
{
	int fa=find(a);
	int fb=find(b);
	if(fa!=fb) father[fb]=fa;
}


double dis(int x1,int y1,int x2,int y2){  //计算两点之间的距离
	return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}

int main()
{	
	scanf("%d%d",&n,&d);
	init();
	for(int i=1;i<=n;i++)
	  scanf("%d%d",&point[i].x,&point[i].y);
	  
	while(scanf("%c",&x)==1)
	{
		if(x=='O')  //修复该点
		{
			scanf("%d",&a);
			open[a]=1;	 //记录修复
			for(int i=1;i<=n;i++)
			{
			//与每个点比较,两点都开放且距离小于d,则合并
				if(open[i] && i!=a && dis(point[i].x,point[i].y,point[a].x,point[a].y)<=(double)d)
					Union(i,a);
			}
		} 
		else if(x=='S') //判断两点是否可通
		{
			scanf("%d%d",&a,&b);
			if(find(a)==find(b)) printf("SUCCESS\n");  //在一个集合里
			else printf("FAIL\n");
		}  
	} 
	return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值