【 POJ - 2492 】F - A Bug‘s Life (种类/分类 并查集)

题目:

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.


思路:

找出txl的虫虫(雌雌 || 雄雄)

种类并查集:多开一倍的数组,若有n数量,用1+n表示1的对立面(此题代表不同性别),2+n表示2的对立面,以此类推。


代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std; 
const int maxn=2020;
int father[maxn+maxn],a,b;

int find(int x){  //找根,路径压缩
	return x==father[x]?x:father[x]=find(father[x]);
}

void Union(int a,int b)  //合并
{
	int fa=find(a);
	int fb=find(b);
	if(fa!=fb) father[fa]=fb;
}

void init(){ //初始化
	for(int i=1;i<=maxn+maxn;i++) father[i]=i;
}

int main()
{	
	int t,bug,sex;
	scanf("%d",&t);
	for(int i=1;i<=t;i++)
	{
		init();
		int flag=0; //记录是否出现txl的虫
		scanf("%d%d",&bug,&sex);
		while(sex--)
		{
			scanf("%d%d",&a,&b);
			if(flag) continue; //出现过,后面就不用判断
			Union(a,b+bug);
			Union(a+bug,b);
			if(find(a)==find(b)) //同性
			{
				flag=1;
				continue;
			}	
		}
		printf("Scenario #%d:\n",i);
		
		if(flag) printf("Suspicious bugs found!\n\n");
		else printf("No suspicious bugs found!\n\n");
	}
	return 0;
}

在这里插入图片描述

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值