1004 Counting Leaves(求每一层有多少叶子结点) (30分)

22 篇文章 0 订阅

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

题意:
给定一棵树,求它每一层有多少个叶子结点。

思路:
DFS或者BFS
注意:BFS的过程中,先弹出队首元素(即当前访问的结点编号),同时更新最大深度,之后判断当前访问的结点是不是叶子节点。

DFS版本:

#include<bits/stdc++.h>
using namespace std;
const int maxn = 110;

vector<int> Node[maxn];
int leaf[maxn] = {0};   //每一层叶子结点的个数

int max_h = 1;      //树的深度
void DFS(int index, int depth)
{
    max_h = max(depth, max_h);
    if(Node[index].size() == 0)     //如果是叶子结点
    {
        leaf[depth]++;      //该层叶子结点个数+1
        return;     //一定要return
    }

    for(int i = 0; i < Node[index].size(); i++)
        DFS(Node[index][i], depth + 1);
}



int main()
{

    int n, m;
    int parent, k, child;
    scanf("%d%d", &n, &m);
    for(int i = 0; i < m; i++)
    {
        scanf("%d%d", &parent, &k);
        for(int j = 0; j < k; j++)
        {
            scanf("%d", &child);
            Node[parent].push_back(child);
        }
    }
    DFS(1, 1);
    printf("%d", leaf[1]);
    for(int i = 2; i <= max_h; i++)
    {
        printf(" %d", leaf[i]);
    }
    return 0;
}

BFS版本

#include<bits/stdc++.h>
using namespace std;
const int maxn = 110;
vector<int> G[maxn];
int h[maxn] = {0};      //各结点所处的层号,从1开始
int leaf[maxn] = {0};   //每一层叶子结点个数
int max_h = 0;  //最大深度

void BFS()
{
    queue<int> q;
    q.push(1);      //根结点入队
    while(!q.empty())
    {
        int id = q.front();     //取队首元素
        q.pop();    //队首元素出队
        max_h = max(max_h, h[id]);      //出队之后更新最大深度
        if(G[id].size() == 0)   //叶子结点
            leaf[h[id]]++;      
        for(int i = 0; i < G[id].size(); i++)   //访问所有子结点
        {
            h[G[id][i]] = h[id] + 1;    //子结点编号为G[id][i]
            q.push(G[id][i]);           //子结点入队
        }
    }
}

int main()
{
    int n, m, k, parent, child;
    scanf("%d%d",&n, &m);
    for(int i = 0; i < m; i++)
    {
        scanf("%d%d", &parent, &k);
        for(int j = 0; j < k; j++)
        {
            scanf("%d", &child);
            G[parent].push_back(child);
        }
    }
    h[1] = 1;   //初始化根结点
    BFS();  //BFS入口
    for(int i = 1; i <= max_h; i++)
    {
        printf("%d", leaf[i]);
        if(i != max_h)  printf(" ");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值