1004 Counting Leaves (30分)---BFS

37 篇文章 0 订阅

https://pintia.cn/problem-sets/994805342720868352/problems/994805521431773184

1004 Counting Leaves (30分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

#include<bits/stdc++.h>
using namespace std;
int main() {
	int N,M;
	scanf("%d%d",&N,&M);
	vector<int>v[101]; //用来存储每个结点的子节点,没有子节点则size()=0 
	int id,n;
	while(M--) {
		int son;
		scanf("%d%d",&id,&n);
		while(n--) {
			cin>>son;
			v[id].push_back(son);
		}
	}
	int root=1,count=0,p;//开始时root为01 
	queue<int>Q; 		//层次遍历 
	Q.push(root);
	while(!Q.empty()) {
		int t=Q.front(),i;
		Q.pop();
		if(v[t].size()==0)count++;  //叶结点的话count++ 
		else {
			for(i=0; i<v[t].size(); i++) {	//不是叶结点的把子节点加入队列 
				Q.push(v[t][i]);
				p=v[t][i];		//记录每一次最后一个加入的结点id 
			}
		}
		if(t==root) {			//当这一层的最后一个结点输出时 
			printf("%d",count); //输出叶结点数 
			if(!Q.empty())printf(" ");
			count=0;			//count置零用来计数下一层叶节点数 
			root=p;				//更新下一层最后一个结点id 
		}
	}
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值