Trie字符串存储查找

题目描述

维护一个字符串集合,支持两种操作:

  1. I x 向集合中插入一个字符串 x;
  2. Q x 询问一个字符串在集合中出现了多少次。

共有 N 个操作,所有输入的字符串总长度不超过 10^5,字符串仅包含小写英文字母。

输入格式

第一行包含整数 N,表示操作数。

接下来 N 行,每行包含一个操作指令,指令为 I x 或 Q x 中的一种。

输出格式

对于每个询问指令 Q x,都要输出一个整数作为结果,表示 x 在集合中出现的次数。

每个结果占一行。

数据范围

1 ≤ N ≤ 2∗10^4

输入样例:

5
I abc
Q abc
Q ab
I ab
Q ab

输出样例: 

1
0
1

 代码实现

import java.util.*;

public class Main{
    static int N = 100010;
    static int[][] son = new int[N][26]; //每个结点的儿子结点
    static int[] cnt = new int[N]; // 以该结点结尾的数量
    static char[] str = new char[N];
    static int idx;
    public static void main(String[] args){
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        while(n -- > 0){
            String op = sc.next();
            String str = sc.next();
            
            if(op.equals("I")) insert(str.toCharArray());
            else if(op.equals("Q")) {
                System.out.println(query(str.toCharArray()));
            }
        }
    }
    
    
    public static void insert(char[] str){
        int p = 0;
        for(int i = 0; i < str.length; i ++){
            int u = str[i] - 'a';
            if(son[p][u] == 0) son[p][u] = ++idx;
            
            p = son[p][u];
        }
        cnt[p] ++;
    }
    
    public static int query(char[] str){
        int p = 0;
        for(int i = 0; i < str.length; i ++){
            int u = str[i] - 'a';
            if(son[p][u] == 0) return 0;
            
            p = son[p][u];
        }
        return cnt[p];
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值