题目描述
给定一个 n×m 的二维整数数组,用来表示一个迷宫,数组中只包含 00 或 11,其中 00 表示可以走的路,11 表示不可通过的墙壁。
最初,有一个人位于左上角 (1,1)(1,1) 处,已知该人每次可以向上、下、左、右任意一个方向移动一个位置。
请问,该人从左上角移动至右下角 (n,m) 处,至少需要移动多少次。
数据保证 (1,1)(1,1) 处和 (n,m) 处的数字为 00,且一定至少存在一条通路。
输入格式
第一行包含两个整数 n 和 m。
接下来 n 行,每行包含 m 个整数(00 或 11),表示完整的二维数组迷宫。
输出格式
输出一个整数,表示从左上角移动至右下角的最少移动次数。
数据范围
1≤n,m≤100
输入样例:
5 5
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
输出样例:
8
代码实现
import java.util.*;
import java.io.*;
public class Main{
static int [][] map;
static int [][] d;
static int[] dx = {1, -1, 0, 0};
static int[] dy = {0, 0, 1, -1};
static int n, m;
public static void main(String[] args) throws Exception{
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
String[] s = br.readLine().split(" ");
n = Integer.parseInt(s[0]);
m = Integer.parseInt(s[1]);
map = new int[n][m];
d = new int[n][m];
for(int i = 0; i < n; i ++){
String[] str = br.readLine().split(" ");
for(int j = 0; j < m; j ++)
map[i][j] = Integer.parseInt(str[j]);
}
System.out.println(bfs());
}
public static int bfs(){
Queue<Pair> q = new LinkedList<Pair>();
q.offer(new Pair(0, 0));
while(! q.isEmpty()){
Pair pair = q.poll();
if(pair.x == n -1 && pair.y == m - 1)
break;
for(int i = 0; i < 4; i ++){
int x = pair.x + dx[i];
int y = pair.y + dy[i];
if(x >= 0 && x < n && y >= 0 && y < m && map[x][y] == 0 && d[x][y] == 0){
q.offer(new Pair(x, y));
d[x][y] = d[pair.x][pair.y] + 1;
}
}
}
return d[n - 1][m - 1];
}
}
class Pair{
int x;
int y;
public Pair(int x, int y){
this.x = x;
this.y = y;
}
}