定义一个复数类Complex,重载运算符“+”,“-”,“*”,“/”,使之能用于复数的加、减、乘、除。运算符重载函数作为Complex类的成员函数。编写程序,分别求两个复数之和、差、积和商。

【问题描述】

定义一个复数类Complex,重载运算符“+”,“-”,“*”,“/”,使之能用于复数的加、减、乘、除。运算符重载函数作为Complex类的成员函数。编写程序,分别求两个复数之和、差、积和商。
Input

两个复数
Output

两个复数之和、差、积和商
Sample Input

3 4 5 -10
Sample Output

c1+c2=(8.00,-6.00i)

c1-c2=(-2.00,14.00i)

c1*c2=(55.00,-10.00i)

c1/c2=(-0.20,0.40i)

#include  <iostream>
#include  <iomanip>
using  namespace  std;
class  Complex
{
public:
	Complex();
	Complex(double  r, double  i);
	Complex  operator+(Complex  &c2);
	Complex  operator-(Complex  &c2);
	Complex  operator*(Complex  &c2);
	Complex  operator/(Complex  &c2);
	void  display();
private:
	double  real;
	double  imag;
};
//补充各成员函数定义

Complex::Complex()
{
	 real = imag=0;
}
Complex::Complex(double r, double i)
{
	real = r;
	imag = i;
}
Complex Complex::operator+(Complex &c2)
{
	Complex cn;
	cn.real = real + c2.real;
	cn.imag = imag + c2.imag;
	return cn;
}
Complex Complex::operator-(Complex &c2)
{
	Complex cn;
	cn.real = real - c2.real;
	cn.imag = imag - c2.imag;
	return cn;
}
Complex Complex::operator*(Complex &c2)
{
	Complex cn;
	cn.real = real * c2.real-imag*c2.imag;
	cn.imag = imag *c2.real+real* c2.imag;
	return cn;
}
Complex Complex::operator/(Complex &c2)
{
	Complex cn;
	cn.real = (real * c2.real + imag*c2.imag)/(c2.real*c2.real+c2.imag*c2.imag);
	cn.imag = (imag *c2.real - real* c2.imag)/(c2.real*c2.real + c2.imag*c2.imag);
	return cn;
}
void Complex::display()
{
	cout << "(" << real << "," << imag << "i)"<<endl;
}
/*  主函数已给定如下  */
int  main()
{
	double  real, imag;
	cin >> real >> imag;
	Complex  c1(real, imag);
	cin >> real >> imag;
	Complex  c2(real, imag);
	cout << setiosflags(ios::fixed);
	cout << setprecision(2);
	Complex  c3 = c1 + c2;
	cout << "c1+c2=";
	c3.display();
	c3 = c1 - c2;
	cout << "c1-c2=";
	c3.display();
	c3 = c1*c2;
	cout << "c1*c2=";
	c3.display();
	c3 = c1 / c2;
	cout << "c1/c2=";
	c3.display();
	return  0;
}
  • 2
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值