npm WARN deprecated core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage

npm 同时被 2 个专栏收录
3 篇文章 0 订阅
19 篇文章 0 订阅

错误
npm WARN deprecated core-js@2.6.11: core-js@❤️ is no longer maintained and not recommended for usage due to the number
of issues. Please, upgrade your dependencies to the actual version of core-js@3.
npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.

解释
npm WARN已弃用的core-js@2.6.11: core-js@<3不再维护,由于数量原因,不推荐使用
问题。请将您的依赖项升级到core-js@3的实际版本。
npm WARN已弃用chokidar@2.1.8: Chokidar 2将在节点v14+上断开。升级到chokidar 3,依赖性降低15倍
名词解释
core-js是什么
-它是JavaScript标准库的polyfill
-它尽可能的进行模块化,让你能选择你需要的功能
-它可以不污染全局空间
-它和babel高度集成,可以对core-js的引入进行最大程度的优化
core-js@3废弃了babel-polyfill,实现了完全无污染的API转译,非常有潜力,但是其暂时会增加打包体积,这个还得看未来普及度上来之后的权衡

chokidar用于监听文件、文件夹变化

解决方法
因为vue cli 升级至v4后,将内部的core-js依赖升级到v3,所以需要我们给core-js做一个升级 npm install -g core-js@3.1.1也可以npm i core-js(v3以上的都行,目前发布到3.6.5),或者改一下 nuxt.config.js 中的配置 。为什么升级呢?因为vue cli中nuxt.js默认依赖的是core-js 2

chokidar发布的版本到3.4.2 npm i chokidar

  • 4
    点赞
  • 5
    评论
  • 8
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 像素格子 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值